'VRUNDEN'

15/11/2010 - 17:44 von Juergen Roesener | Report spam
Hallo zusammen,

zuerst einmal habe ich als Neuling in dieser NG die letzten 300
Beitràge überflogen, leider aber nichts zu meinem kleinen Problem
gefunden:

Mit Excel 95 habe ich in einer Tabelle VRUNDEN für 0,25-Schritte
benutzt; das hat - wenn man auf die Vorzeichen achtet - immer sehr
schön funktioniert. Nun muss ich gelegentlich Tabellen, die VRUNDEN
enthalten, auf einem WIN 7 Rechner mit Excel 2007 bearbeiten. Die
bearbeiteten Tabellen (im Kompatibilitàtsmodus) sollen spàter wieder
zurück auf den Rechner mit Excel 95.

Wenn ich auf dem WIN 7 Rechner die mit Excel 95 erstellte Tabelle
öffne, stehen die zuvor berechneten Werte zwar in den entsprechenden
Feldern, eine Neuberechnung ist aber mit Excel 2007 nicht mehr
möglich. VRUNDEN ist in den Feldern nicht mehr vorhanden, statt dessen
steht dort =#NV. Wird diese Tabelle dann auf den Rechner mit Excel 95
zurück übertragen, bleibt VRUNDEN auch dort verschwunden und wird
natürlich auch nicht mehr ausgeführt.

Als workaround berechne ich die Felder zur Zeit mit einer ellenlangen
Formel "=WENN(GANZZAHL...)" Das funktioniert zwar
zufriedenstellend, erscheint mir aber sehr wenig elegant.

Was mache ich falsch?

TIA und Gruß
Jürgen
 

Lesen sie die antworten

#1 Claus Busch
15/11/2010 - 18:02 | Warnen spam
Hallo Jürgen,

VRUNDEN gibt es in xl2007 aber auch. Es kann nur sein, dass es in der
früheren Version auf andere Art eingebaut ist. Vieles was früher in
AddIns gesteckt hat, ist heute direkt in den Funktionen enthalten. Öffne
mal die Datei und gehe auf Suchen und Ersetzen. Suche (Gleichheitszeichen) und ersetze durch =. Dadurch sollten sich die
Formeln neu berechnen.
Musst du unbedingt VRUNDEN nutzen? Eine Zahl in A1 kann man auch mit
=RUNDEN(A1*4;0)/4
auf 0,25er Schritte runden.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen