11.2: capiinit ERROR: cannot open /dev/capi20 nor /dev/isdn/capi20 - Is a directory (21)

22/11/2009 - 19:16 von Tilman Schmidt | Report spam
Nach dem Update auf 11.2 kann ich das CAPI-Subsystem nicht mehr starten.
Unter 10.3 ging das mit "capiinit" einwandfrei. Jetzt endet das mit der
Fehlermeldung:

xenon:/home/ts # capiinit
ERROR: cannot open /dev/capi20 nor /dev/isdn/capi20 - Is a directory (21)

Und capiinfo sagt anschließend:

xenon:/home/ts # capiinfo
capi not installed - Success (0)

Im Syslog steht dazu:

Nov 22 16:12:43 xenon kernel: [ 191.136739] capifs: Rev 1.1.2.3
Nov 22 16:12:43 xenon udevd-work[3696]: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory
Nov 22 16:12:43 xenon kernel: [ 191.167367] capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)

Die Module sind geladen und scheinen auch zu funktionieren:

xenon:/home/ts # lsmod | fgrep capi
capi 12608 0
capifs 3236 2 capi
kernelcapi 41206 2 capi,gigaset
xenon:/home/ts # cat /proc/capi/controller
1 gigaset running bas_gigaset bas_gigaset

Aber CAPI-Anwendungen funktionieren nicht, und die /dev-Dateien sehen
auch nicht gut aus:

xenon:/home/ts # ls -ld /dev/capi20 /dev/isdn/capi20 /dev/capi /dev/capi/.udev-tmp
ls: cannot access /dev/capi20: No such file or directory
ls: cannot access /dev/capi/.udev-tmp: No such file or directory
drw-rw- 2 root dialout 680 Nov 22 16:18 /dev/capi
lrwxrwxrwx 1 root root 8 Nov 22 16:18 /dev/isdn/capi20 -> ../capi/

Ideen?
 

Lesen sie die antworten

#1 Oliver Föhr
22/11/2009 - 20:23 | Warnen spam
Am 22.11.2009 19:16, schrieb Tilman Schmidt:
Nach dem Update auf 11.2 kann ich das CAPI-Subsystem nicht mehr starten.
Unter 10.3 ging das mit "capiinit" einwandfrei. Jetzt endet das mit der
Fehlermeldung:

xenon:/home/ts # capiinit
ERROR: cannot open /dev/capi20 nor /dev/isdn/capi20 - Is a directory (21)

Und capiinfo sagt anschließend:

xenon:/home/ts # capiinfo
capi not installed - Success (0)

Im Syslog steht dazu:

Nov 22 16:12:43 xenon kernel: [ 191.136739] capifs: Rev 1.1.2.3
Nov 22 16:12:43 xenon udevd-work[3696]: rename(/dev/capi/.udev-tmp, /dev/capi/) failed: Not a directory
Nov 22 16:12:43 xenon kernel: [ 191.167367] capi20: Rev 1.1.2.7: started up with major 68 (middleware+capifs)

Die Module sind geladen und scheinen auch zu funktionieren:

xenon:/home/ts # lsmod | fgrep capi
capi 12608 0
capifs 3236 2 capi
kernelcapi 41206 2 capi,gigaset
xenon:/home/ts # cat /proc/capi/controller
1 gigaset running bas_gigaset bas_gigaset

Aber CAPI-Anwendungen funktionieren nicht, und die /dev-Dateien sehen
auch nicht gut aus:

xenon:/home/ts # ls -ld /dev/capi20 /dev/isdn/capi20 /dev/capi /dev/capi/.udev-tmp
ls: cannot access /dev/capi20: No such file or directory
ls: cannot access /dev/capi/.udev-tmp: No such file or directory
drw-rw- 2 root dialout 680 Nov 22 16:18 /dev/capi
lrwxrwxrwx 1 root root 8 Nov 22 16:18 /dev/isdn/capi20 -> ../capi/

Ideen?




Dazu habe ich schon einen Bug report verfasst.

Lege /dev/capi20 an.

Schau mal hier:

http://www.foehr-it.de/hlp/viewtopic.php?t17

olly




** Hi! I'm a signature virus! Copy me into your signature, please! **

Ähnliche fragen