2 Fragen zu Grub 1/openSUSE 11.0

17/02/2010 - 21:42 von Uwe Premer | Report spam
Nabend,

irgendwie hatte ich mir durch verschiedene Installationen mit einem
USB-Stick die Konfiguration von fstab und auch menu.lst verbogen.
Meine openSUSE wollte daraufhin nicht mehr starten.
Konnte das aber durch einige Korrekturen in den beiden obig genannten
Dateien wieder soweit hinbringen, dass die extra-Home-Partition wieder
gemountet wird beim Starten und die SUSE wieder mit KDE3 zur Verfügung
steht.

Jetzt gibt es noch ein paar Kleinigkeiten, die bei Grub kleine
Fehlermeldungen ergeben.
Vorab noch einige Systemdaten:
mein openSUSE 11.0-rootSystem liegt auf /dev/sda6,
Home liegt auf /dev/sda7,
swap liegt auf /dev/sda9
(auf /dev/sda8 liegt Ubuntu Karmic inkl. root und Home).

Die Zeile
gfxmenu (hd0,6)/boot/message
in der menu.lst bringt irgendeine Fehlermeldung beim Booten.
Ich hatte sie aus einem menu.lst-Backup reinkopiert.
Brauche ich die Zeile überhaupt?
Bzw. ist dort (hd0,6) überhaupt richtig?

Übrigens gibt es die Datei /boot/message in der Tat.

Des weiteren habe ich die Frage, was "resume=/dev/sda7" in folgender
Zeile überhaupt macht? Und muß da vll. doch die Swap-Partition
aufgeführt werden? Oder geht es wirklich ums Home?

kernel /boot/vmlinuz-2.6.27.29-0.4-default
root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HM320JIS16LJ10PC02046-part6
resume=/dev/sda7 splash=silent showopts vga=0x317

Falls Ihr weitere Angaben braucht, liefere ich die gerne nach.
Vll. noch was aus /var/log/messages oder so?

Uwe
System: IBM Lenovo R60, Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz
OS: openSUSE 11.0 (x86_64)
Kernel: Linux 2.6.27.29-0.4.1-default x86_64
KDE: 3.5.10 "release 55"
 

Lesen sie die antworten

#1 Uwe Premer
17/02/2010 - 22:41 | Warnen spam
Am Mittwoch, 17. Februar 2010 21:42 schrieb /myself:

Ich hàtte das Posting auch canceln können, lasse es aber lieber mal stehen,
dann können andere das Problem ggf. nachvollziehen.

Die Zeile
gfxmenu (hd0,6)/boot/message



Habe es geàndert auf (hd0,5), so sollte es stimmen. Keine Fehlermeldung mehr.

Des weiteren habe ich die Frage, was "resume=/dev/sda7" in folgender
Zeile überhaupt macht? Und muß da vll. doch die Swap-Partition
aufgeführt werden? Oder geht es wirklich ums Home?

kernel /boot/vmlinuz-2.6.27.29-0.4-default
root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HM320JIS16LJ10PC02046-part6
resume=/dev/sda7 splash=silent showopts vga=0x317



Aus dem Netz selbst entnommen: resume bezeichnet diejenige Partition für ein
Suspend to disk. Da mein Swap auf sda9 liegt, hab ich das nun
auf "resume=/dev/sda9" abgeàndert.

Jetzt làuft meine Suse wieder wie geschmiert.

Uwe
System: IBM Lenovo R60, Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz
OS: openSUSE 11.0 (x86_64)
Kernel: Linux 2.6.27.29-0.4.1-default x86_64
KDE: 3.5.10 "release 55"

Ähnliche fragen