2 Matrizen vergleichen

22/07/2008 - 10:26 von logzone | Report spam
Hallo!

Ich habe folgendes Problem:

Ich hab 2 Dateien, die erste mit einer Spalte mit Postleitzahlen:

50226
20255
20761
34251

Die 2. Datei enthaelt 2 Spalten:

50226 DEHAM
32658 NLRTM
20761 BEANR
54215 GBFXT

Ich moechte nun gerne eine Funktion haben, die in der 2. Datei
nachschaut, ob uebereinstimmende PLZs vorhanden sind und wenn ja, dann
sollen die Codes aus der 2. Spalte in die erste Datei uebernommen
werden.

Ich denke, dass man das wohl irgendwie mit INDEX und SVERWEIS
hinbekommen koennte, bin da aber ein wenig ueberfordert.

Fuer Eure Hilfe waer ich wirklich dankbar!

Gruss
Axel
 

Lesen sie die antworten

#1 Eberhard Funke
22/07/2008 - 11:21 | Warnen spam
Am Tue, 22 Jul 2008 01:26:19 -0700 (PDT) schrieb :

Ich hab 2 Dateien, die erste mit einer Spalte mit Postleitzahlen:

50226
20255
20761
34251

Die 2. Datei enthaelt 2 Spalten:

50226 DEHAM
32658 NLRTM
20761 BEANR
54215 GBFXT

Ich moechte nun gerne eine Funktion haben, die in der 2. Datei
nachschaut, ob uebereinstimmende PLZs vorhanden sind und wenn ja, dann
sollen die Codes aus der 2. Spalte in die erste Datei uebernommen
werden.




Hallo Axel,

die erste Datei in Tabelle1 A1:A4, die zweite in Tab2 A1:B4

Tabelle1 B1:
=WENN(ISTFEHLER(SVERWEIS(A1;Tabelle2!$A$1:$B$4;2;FALSCH));"";SVERWEIS(A1;Tabelle2!$A$1:$B$4;2;FALSCH))

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen