[2k3] Vergleichen mit Ausnahmen

13/09/2007 - 16:19 von Erik Harren | Report spam
Tachchen!

Ich möchte in Excel innerhalb einer Zeile vegleichen, ob ein Datum vor
einem vorangegangenen Termin liegt. Dabei gilt es zu beachten, dass in
den Zellen auch einmal ein '- stehen könnte. Dieser Vergleich soll mir
dann in der Bedingten Formatierung farblich gekennzeichnet werden.

Bis dato versuche ich mich auf diese Art, bei der ich noch nciht ganz
glücklich sein kann (für Zelle H33):

=UND(NICHT(ODER($G33="-";$F33="-";$E33="-";$D33="-";$C33="-"));
ODER($H33<$G33;$H33<$F33;$H33<$E33;$H33<$D33;$H33<$C33))

Die Spalten sind mit Datumsanzeigen versehen, die spaltenweise
aufsteigend eingegeben werden sollten (größer gleich halt, da einige
Produktionsschritte am selben Tag stattfinden könnten) oder halt
ausgelassen werden können ('-). Es kommt also vor, dass die Eingaben
wiefolgt aussehen:

SpalteC;SpalteD;SpalteE;SpalteF;SpalteG;SpalteH
1.4.07;'-;2.4.07;'-;3.4.07;2.4.07
1.4.07;'-;2.4.07;'-;'-;2.3.07
1.4.07;'-;'-;'-;'-;2.3.07

In diesen Fàllen muss natürlich Spalte H aufleuchten, im Gegentum zu den
nachfolgenden:

SpalteC;SpalteD;SpalteE;SpalteF;SpalteG;SpalteH
1.4.07;'-;2.4.07;'-;2.4.07;2.4.07
1.4.07;'-;2.4.07;'-;'-;2.4.07
1.4.07;'-;'-;'-;'-;2.4.07

Wo habe ich meinen Dànkfàhla eingebaut?

Gruß,
Erik.
 

Lesen sie die antworten

#1 Bernd P
13/09/2007 - 18:01 | Warnen spam
Hallo Erik,

Selektiere D1:H999 (Zelle D1 zuerst) und gib als bedingte
Formatierung, Formel ist, ein:
=IF(D1<>"-";SUMMENPRODUKT(--
(D1>=WENN($C1:C1="-";D1;$C1:C1)))<>SPALTE(D1)-SPALTE($C1);FALSCH)
Wàhle z. B. einen roten Hintergrund.

Viele Grüße,
Bernd

PS: Nie glauben, immer testen.

Ähnliche fragen