Forums Neueste Beiträge
 

3 WENN Abfragen in einer, falsche Ausgabe

16/01/2011 - 11:23 von Maria Feizelmeier | Report spam
Ich habe in drei Felder jeweils eine dieser WENN Abfragen

=WENN(D2>A2;"";"ABLEHNUNG G")

=WENN(B2>A2;"";"ABLEHNUNG B")

=WENN(C2>HEUTE();"";"Groesse HEUTE")

Nun möchte ich diese in eine zusammenfügen:

=WENN(D2>A2;WENN(B2>A2;WENN(C2>HEUTE();"";"Groesser HEUTE");"Groesser
B");"Groesser G")

jetzt habe ich aber das Problem, das bei der letzten WENN Abfrage ein Fehler
rauskommt, und zwar wenn die Formel in einer leeren Zeile ausgeführt wird,
kommt Groesser HEUTE, doch es sollte nichts ausgegeben werden, da ja kein
Wert vorhanden ist. Bei den einzel Abfragen funktioniert es einbandfrei.


Maria
 

Lesen sie die antworten

#1 Berthold Erfkämper
16/01/2011 - 11:46 | Warnen spam

=WENN(C2>HEUTE();"";"Groesse HEUTE")




Hallo Maria,

wenn ich das richtig verstehe, dann soll, wenn in Zelle C2 zB. ein Datum
steht, das grösser ist als heute(), "Grösser HEUTE" stehen. Oder?
Im Moment aber wird "Grösser HEUTE" ausgegeben wenn du kleiner bist als
Zelle C2.
Versuche es doch mal so:

=wenn(c2<heute();"";"Grösser HEUTE")

Gruss.

Berthold

Ähnliche fragen