433MHz-Empfängermodul Conrad 130428: Ausgangsspannung

15/12/2012 - 20:11 von Ralph Aichinger | Report spam
Ich hab mir so ein Conrad-Funkmodulset für 433MHz gekauft,

http://www.conrad.de/ce/de/product/...nt=Default

Leider in meiner Naivitàt zu wenig genau das Datenblatt studiert.
Das Ding liefert nàmlich anscheinend bei Empfang nur 0.8V für High
wenn ich das Datenblatt richtig verstehe. Würde auch mit meiner
Messung mit dem Multimeter korrespondieren, da hab ich so ca.
0.5V Anzeige, wenn ich ein Signal schicke, was ja bei so einem
modulierten Signal zu den 0.8V passen könnte.

Jetzt möchte ich das mit der RFswitch-Library am Arduino verwenden:

http://code.google.com/p/rc-switch/...To_Receive

dort ist eine direkte Verbindung mit dem Digitaleingang
vorgeschlagen. Ich vermute, es liegt am geringen Pegel
(der Arduino làuft mit 5V-Logik) daß ich nix empfange
(ich hab noch nicht den "richtigen" Sender, aber
immerhin einen von einer Wetterstation, der auf
der gleichen Frequenz sendet, und auch diese Ausschlàge
im 0.5V-Bereich bringt) bzw. möglicherweise bloß
die Library nix dekodiert.

Ich hab leider kein Oszi um mir die Spitzen anzusehen,
aber was würdet ihr raten? Soll ich einfach einen
Transistor dazwischenschalten und das Signal etwas
anheben?

Soll ich mal probieren, ob ein Teil mit 3.3V-Logik
was sieht, hab ich da Chancen?

TIA
/ralph
 

Lesen sie die antworten

#1 Joerg
15/12/2012 - 21:00 | Warnen spam
Ralph Aichinger wrote:
Ich hab mir so ein Conrad-Funkmodulset für 433MHz gekauft,

http://www.conrad.de/ce/de/product/...nt=Default

Leider in meiner Naivitàt zu wenig genau das Datenblatt studiert.
Das Ding liefert nàmlich anscheinend bei Empfang nur 0.8V für High
wenn ich das Datenblatt richtig verstehe.




In der Anleitung steht es tatsaechlich, obwohl ein LM2904 im
Comparator-Betrieb laut Datenblatt bei 5V Betrieb auf mindestens 3V
kommen sollte:

http://www.produktinfo.conrad.com/d...433MHz.pdf


... Würde auch mit meiner
Messung mit dem Multimeter korrespondieren, da hab ich so ca.
0.5V Anzeige, wenn ich ein Signal schicke, was ja bei so einem
modulierten Signal zu den 0.8V passen könnte.

Jetzt möchte ich das mit der RFswitch-Library am Arduino verwenden:

http://code.google.com/p/rc-switch/...To_Receive

dort ist eine direkte Verbindung mit dem Digitaleingang
vorgeschlagen. Ich vermute, es liegt am geringen Pegel
(der Arduino làuft mit 5V-Logik) daß ich nix empfange
(ich hab noch nicht den "richtigen" Sender, aber
immerhin einen von einer Wetterstation, der auf
der gleichen Frequenz sendet, und auch diese Ausschlàge
im 0.5V-Bereich bringt) bzw. möglicherweise bloß
die Library nix dekodiert.

Ich hab leider kein Oszi um mir die Spitzen anzusehen,
aber was würdet ihr raten? Soll ich einfach einen
Transistor dazwischenschalten und das Signal etwas
anheben?

Soll ich mal probieren, ob ein Teil mit 3.3V-Logik
was sieht, hab ich da Chancen?




Wenn Du nur 0.8V misst dann nicht. Ein Comparator mit auf 400mV
gesetzter Schwelle waere das beste. Aber ein Transistor mit 1k in Serie
zur Basis und 5-10k von V+ nach Kollektor sollte auch gehen. Jedoch nur
fuer Hobby, ein Produkt wuerde ich nicht so auf Kante naehen denn da
sind nur rund 200mV Reserve.

Gruesse, Joerg

http://www.analogconsultants.com/

Ähnliche fragen