50% Auslastung der CPU

30/11/2007 - 14:49 von Michael Kolowicz | Report spam
Einen wunderschönen Tag wünsche ich allen an dieser Stelle.

Wollte mal fragen, ob jemand das selbe Problem hat (hatte) wie ich
gerade:

Ich habe eine umfangreiche Solution (19 Projekte). Bin gerade in einem
Teilprojekt am schaffen. Seit einiger Zeit dauert es ab und zu recht
lange bis das Projekt nach einer Änderung (z.B. das auskommentieren
einer einzigen Zeile) wieder erstellt wurde. Dabei wird der ganze
Rechner blokiert (CPU0%). Wenn ich die Änderung wieder zurücknehme
oder auch etwas anderes àndere kann es sein, das es beim Erstellen dann
recht schnell geht.

Seit heute noch ein weiteres Problem: Wenn ich in der Design-view was
àndere oder eine Änderung im Dataset mache und speichern will, hàngt
sich VS2005 anscheinend auf. In Wirklichkeit ist es nur stark
beschàftigt (konstante 50% CPU und der Speicherverbrauch steigt ins
unermessliche 400-500MB). dann kann es bis zu 5 Minuten dauern, bis man
wieder eine Eingabe in VS machen kann.

Ähnliches Verhalten, wenn die Ansicht in der Designer-View aktualisiert
wird.

Reperaturinstalltion von VS2005 und anschließendes SP1 installieren
haben keine Verànderung gebracht.

Also nun die frage: Hatte das schon mal jemand von euch? Wie hat er es
wieder wegbekommen?

Vielen Dank für eure tipps

BTW: Der Virenscanner ist es anscheinend nicht, den habe ich testweise
mal deaktiviert und trotzdem hat sich das verhalten nicht geàndert
 

Lesen sie die antworten

#1 Michael Kolowicz
03/12/2007 - 11:39 | Warnen spam
In article ,
Hier noch einige Details zu meinem Problem:

Folgende erfolglose Versuche habe ich getàtigt (einige Ideen stammen aus
Google und Co.):

1.) Reperaturinstalltion von VS2005
2.) SP1 von VS2005 nochmals installiert
3.) Entfernen und Neuinstallation von VS2005 (anschließend SP1)
4.) Installation von SP2 für Windows XP
5.) Installtion aller Patches für Windows XP
6.) Starten der devenv.exe /safemode
7.) Starten der devenv.exe /resetuserdata
8.) Entfernen und Tauschen der Speicherriegel
9.) Kollege hat Projekt aus SVN gelesen und auf neu installierter
Maschine gestartet. Er hat keine Probleme wie beschrieben
10.) Start von XP mit nur einer CPU (statt als DualCore)
11.) Mit ProcessExplorer versucht den Prozess zu finden, der Blockiert
(ist aber nur die DevEnv.exe)
12.) Mit FileMon versucht irgentwelche fehlerhaften Schreibzugriffe zu
finden
13.) Auslagerungsdatei gelöscht und neu erstellen lassen
14.) Defragmentieren und Bereinigen der Festplatte


Zum Reproduzieren des Fehlers gehe ich folgendermasen vor:
Lade das Projekt in VS2005 - Gehen dann in mein UserControl (in VB.NET
geschreiben) - Nehme irgendein Datagridview und veràndere die Datasource
und stelle sie wieder zurück (mit dem Assistenten) - Nun müssten auf dem
Reiter ein Sterchen erscheinen - gehe nun in das Dataset des Projekts
(nicht auf dem UserControl) - Doppelklick auf irgendeine Verbindung -
Diese wieder speichern - Nun wechseln auf die DesignView des
Usercontrols - Normalerweise müsste jetzt ein refresh erfolgen. Wenn
dieser Refresh erfolgt dauert es bis zu 5 Minuten das ich wieder was
machen kann. Devenv.exe geht dann auf 50% (DualCore-rechner; einer also
mit CPU0%)


Vielleicht hat ja noch jemand eine Idee wo man etwas finden könnte bzw.
woran es noch liegen könnte

says...
Einen wunderschönen Tag wünsche ich allen an dieser Stelle.

Wollte mal fragen, ob jemand das selbe Problem hat (hatte) wie ich
gerade:

Ich habe eine umfangreiche Solution (19 Projekte). Bin gerade in einem
Teilprojekt am schaffen. Seit einiger Zeit dauert es ab und zu recht
lange bis das Projekt nach einer Änderung (z.B. das auskommentieren
einer einzigen Zeile) wieder erstellt wurde. Dabei wird der ganze
Rechner blokiert (CPU0%). Wenn ich die Änderung wieder zurücknehme
oder auch etwas anderes àndere kann es sein, das es beim Erstellen dann
recht schnell geht.

Seit heute noch ein weiteres Problem: Wenn ich in der Design-view was
àndere oder eine Änderung im Dataset mache und speichern will, hàngt
sich VS2005 anscheinend auf. In Wirklichkeit ist es nur stark
beschàftigt (konstante 50% CPU und der Speicherverbrauch steigt ins
unermessliche 400-500MB). dann kann es bis zu 5 Minuten dauern, bis man
wieder eine Eingabe in VS machen kann.

Ähnliches Verhalten, wenn die Ansicht in der Designer-View aktualisiert
wird.

Reperaturinstalltion von VS2005 und anschließendes SP1 installieren
haben keine Verànderung gebracht.

Also nun die frage: Hatte das schon mal jemand von euch? Wie hat er es
wieder wegbekommen?

Vielen Dank für eure tipps

BTW: Der Virenscanner ist es anscheinend nicht, den habe ich testweise
mal deaktiviert und trotzdem hat sich das verhalten nicht geàndert

Ähnliche fragen