6to4 Tunnel: Pakete kommen beim externen Interface an aber nicht im Tunnel-If

05/11/2008 - 14:26 von Peter Mairhofer | Report spam
Hi,

Ich habe ein großes Problem mit einem IPv6 Tunnel von Sixxs. Ich habe
vor einigen Wochen einen WRT54GL (mit OpenWRT) als Router eingerichtet,
der gleichzeitig Zugang zu IPv6 via sixxs Tunnel bietet. Das Werkl ist
sehr lange ohne Probleme gegangen, seit einigen Tagen bekomme ich aber
wie aus heiterem Himmel die Mails "Tunnel downtime [...]".

Starte ich den Tunnel z.B. neu (oder den WRT) geht wieder alles. Das
ganze làuft für einige Zeit und dann auf einmal bricht die Verbindung
ab. Mit tcpdump sehe ich dann die 6to4-Paket im öffentlichen Interface
eintrudeln aber die kommen nicht im "sixxs"-Interface an! Das versteh
ich einfach nicht, wie kann das sein?

# tcpdump -i eth0.1 'proto 41'

# tcpdump -i sixxs

An was kann das liegen und vor allem, wie kann ich den Fehler hier
eingrenzen? Da das ganze ja *innerhalb* des OS geschieht kann Routing &
Co nicht involviert sein (obwohl ich schon die Routingtabellen, Tunnels
etc durchgecheckt habe). Temporàr habe ich auch schon jegliche Policy
von iptables auf ACCEPT gesetzt, geht noch immer nicht.

Und es muss irgendwas sein was erst nach einiger Zeit (ohne eigenem
Zutun) nicht mehr geht...

lg
Peter
 

Lesen sie die antworten

#1 Hauke J. Zuehl
12/11/2008 - 21:56 | Warnen spam
Hi!

Peter Mairhofer wrote:

Hi,


# tcpdump -i eth0.1 'proto 41'

# tcpdump -i sixxs



Schuss ins Blaue: Forwarding auf den IPv6 Interfaces geprüft?


lg
Peter



Gruss,
Hauke
Praevention ist es, das Land und seine Buerger vor Gesetzen des
Innenministers Schaeuble zu bewahren.
(Heribert Prantl)

Ähnliche fragen