74190 gegen 74LS191 tauschen

07/12/2007 - 23:10 von Peter Engels | Report spam
Hallo zusammen,

wie ich in dem Thread "Metallfilmwiderstànde" schrieb, beschàftige ich
mich gerade mit der Modernisierung meines 1979 selbst gebauten
Digitalmultimeters auf TTL-Basis. Das Geràt habe ich mit einer
automatischen Messbereichswahl versehen, die über Reed-Relais
funktioniert. Kernstück dieses Schaltungsdetails ist einen 74190
programmierbarer up/down Counter, der bei Überlauf eins hochzàhlt und
bei Zàhlerwerten unter 380 eins runterzàhlt. Mit dem 74190 funktioniert
das tadellos. Nach Datenblatt hat das Ding eine Leistungsaufnahme von
325mW und wird entsprechend glühend heiß.

Nun fand ich in meiner TTL-Kiste mehrere 74LS191, die nur eine
Leistungsaufnahme von 100mW haben und entsprechend kàlter bleiben
sollten. Unterschied: Der 190 ist ein Dekadenzàhler, der 191 ist ein
BCD-Zàhler. Da ich nur max. 6 Messbereiche habe und die Zàhlerstànde
ohnehin per Logik eingegrenzt werden, sollte dieser Unterschied völlig
belanglos sein.

Da der 74190 eines der ganz wenigen gesockelten ICs ist (vermutlich
weil er so heiß wird ;-), war ein Tausch gegen den 74LS191 ganz leicht
möglich. Aber das Ding will nicht funktionieren: Er steuert bei
Überlauf immer dasselbe Relais an, zàhlt also nicht hoch. Irgendetwas
passiert, das kann man am Klicken der Relais hören.

Das Problem muss am Wechsel TTL zu TTL-LS liegen, ich kann aber die
Ursache nicht finden. Ich habe es allen Pins mit Pullups/downs und Cs
versucht, ohne Erfolg. Der Zàhlerbaustein ist auch schon direkt auf der
Verorgungsspannung mit 100myF/100nF gepuffert.

Hat jemand eine Idee, was man einem Wechsel von TTL zu TTL-LS beachten
muss?

MfG / Regards

Peter Engels

This OS/2 system uptime is 02 hours, 11 minutes and 10 seconds.
Please use the reply-to address for e-mails!
 

Lesen sie die antworten

#1 Bjoern Wieck
08/12/2007 - 00:12 | Warnen spam
Peter Engels schrieb:

Das Problem muss am Wechsel TTL zu TTL-LS liegen, ich kann aber die
Ursache nicht finden. Ich habe es allen Pins mit Pullups/downs und Cs
versucht, ohne Erfolg. Der Zàhlerbaustein ist auch schon direkt auf der
Verorgungsspannung mit 100myF/100nF gepuffert.

Hat jemand eine Idee, was man einem Wechsel von TTL zu TTL-LS beachten
muss?



Hallo Peter

Der LS kann natürlich nicht so viel Strom an den Ausgàngen liefern oder
aufnehmen wie der einfache TTL Baustein.
Warscheinlich wir der Rest deiner Schaltung damit nicht zurechtkommen
wenn Du z. B. viele TTL-Eingànge an einem LS-Ausgang hast und die Stöme
dabei so gross werden das der Pegel für ein Low oder High nicht mehr im
Rahmen bleiben...

Eventuell wurde dein 74190 auch schon deswegen sehr Warm weil seine
Ausgànge über Gebühr belastet wurden.

Dann hast Du mit LS keine Chance, oder du baust alles auf LS um.


Schau Dir mal deinen Schaltplan an ob da bestimmte Ausgànge am 74190
viele TTL-Eingànge treiben müssen und ob es eventuell eine Option für
Dich wàre diese Ausgànge mit Transistoren zu puffern.

Grüße
Björn

Ähnliche fragen