Forums Neueste Beiträge
 

Abhaengigkeits-Probleme in Debian Wheezy

13/07/2012 - 01:06 von Patrick Rudin | Report spam
Ich habe hier einen àlteren Drittrechner, auf dem ich Wheezy schon
einige Wochen nicht mehr aktualisiert habe. Nun scheint sich da
irgendwas zu blockieren:


root@altekiste:/home/taxi# aptitude full-upgrade
Die folgenden NEUEN Pakete werden zusàtzlich installiert:
gir1.2-gck-1{a} gir1.2-gcr-3{a} gir1.2-gdesktopenums-3.0{a}
gir1.2-gnomekeyring-1.0{a} gir1.2-tracker-0.14{a}
libboost-python1.49.0{a} libcheese-gtk21{a} libcheese3{a}
libclutter-imcontext-0.1-bin{a} libebackend-1.2-2{a}
libedata-book-1.2-13{a} libedata-cal-1.2-15{a} libevdocument3-4{a}
libevview3-3{ab} libfarstream-0.1-0{ab} libgxps2{a}
libmeanwhile1{a} libmx-bin{a} libmx-common{a} libpst4{a}
libpurple-bin{a} libpurple0{a} librhythmbox-core6{a}
libtelepathy-farstream2{a} libtracker-extract-0.14-0{a}
libtracker-miner-0.14-0{a} libwacom-common{a} libwacom2{a} libzephyr4{a}
lightsoff{a} pidgin-data{a} swell-foop{a} telepathy-haze{a}
Die folgenden Pakete werden aktualisiert:
apt cheese cheese-common empathy empathy-common evince evince-common
evolution evolution-common evolution-data-server{b}
evolution-data-server-common evolution-exchange evolution-plugins
gir1.2-clutter-1.0 gir1.2-evince-3.0 gir1.2-mutter-3.0
gir1.2-rb-3.0 glchess glines gnect gnibbles gnobots2
gnome-control-center gnome-control-center-data gnome-documents gnome-games
gnome-games-data gnome-panel{b} gnome-panel-data
gnome-settings-daemon gnome-shell gnome-shell-common gnome-sudoku
gnome-sushi{b}
gnomine gnotravex gnotski gtali iagno libchamplain-0.12-0
libchamplain-gtk-0.12-0 libclutter-1.0-0{b} libclutter-gst-1.0-0
libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0
libcluttergesture-0.0.2-0 libcogl-pango0{b} libedataserverui-3.0-1
libevolution
libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
libmutter0 libmx-1.0-2 mahjongg mutter-common nautilus-sendto
nautilus-sendto-empathy python-tagpy quadrapassel rhythmbox
rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins tracker
tracker-extract tracker-gui tracker-miner-evolution tracker-miner-fs
tracker-utils
Die folgenden Pakete werden EMPFOHLEN, aber NICHT installiert:
gnome-online-accounts libclutter-1.0-common mesa-utils
70 Pakete aktualisiert, 33 zusàtzlich installiert, 0 werden entfernt und
0 nicht aktualisiert.
129 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken
werden 58.1 MB zusàtzlich belegt sein.
Die folgenden Pakete haben verletzte Abhàngigkeiten:
gnome-sushi : Beschàdigt: gnome-sushi-common (< 0.4.0-1) aber 0.2.1-3
ist installiert.
libcogl-pango0 : Beschàdigt: libcogl5 (< 1.10.0-1) aber 1.8.2-1 ist
installiert.
libcheese-gtk20 : Hàngt ab von: cheese-common (= 3.2.2-2) aber 3.4.2-1
soll installiert werden.
libcheese1 : Hàngt ab von: cheese-common (= 3.2.2-2) aber 3.4.2-1 soll
installiert werden.
libevview3-3 : Beschàdigt: libevince3-3 aber 3.2.1-1 ist installiert.
libfarstream-0.1-0 : Kollidiert mit: libgstfarsight0.10-0 aber
0.0.31-1+b1 ist installiert.
libept1 : Hàngt ab von: libapt-pkg4.10, welches ein virtuelles Paket ist.
libclutter-1.0-0 : Beschàdigt: libcogl5 aber 1.8.2-1 ist installiert.
evolution-data-server : Beschàdigt: libebook-1.2-12 (< 3.4) aber
3.2.2-1 ist installiert.
Beschàdigt: libebook1.2-10 (< 3.2) aber
3.0.3-2 ist installiert.
gnome-panel : Beschàdigt: libpanel-applet2-0 aber 2.30.2-4+b1 ist
installiert.
Die folgenden Aktionen werden diese Abhàngigkeiten auflösen:

Entfernen der folgenden Pakete:
1) ekiga
2) empathy
3) evince
4) evolution
5) evolution-data-server
6) evolution-exchange
7) evolution-plugins
8) gir1.2-evince-3.0
9) gir1.2-sushi-1.0
10) gnome
11) gnome-applets
12) gnome-contacts
13) gnome-core
14) gnome-desktop-environment
15) gnome-documents
16) gnome-panel
17) gnome-session-fallback
18) gnome-sushi
19) libchamplain-gtk-0.4-0
20) libcheese-gtk20
21) libcheese1
22) libclutter-gtk-0.10-0
23) libcogl5
24) libept1
25) libfolks-eds25
26) libsushi-1.0-0

Beibehalten der folgenden Pakete in ihrer aktuellen Version:
27) libevview3-3 [Nicht installiert]
28) libfarstream-0.1-0 [Nicht installiert]
29) libpurple-bin [Nicht installiert]
30) libpurple0 [Nicht installiert]
31) libtelepathy-farstream2 [Nicht installiert]
32) telepathy-haze [Nicht installiert]

Die folgenden Abhàngigkeiten unaufgelöst lassen:
33) alacarte empfiehlt gnome-panel
34) empathy empfiehlt telepathy-haze
35) epiphany-browser empfiehlt evince
36) evolution-common empfiehlt evolution
37) libfolks25 empfiehlt libfolks-eds25
38) gnome-panel empfiehlt evolution-data-server
39) gnome-panel-data empfiehlt gnome-panel
40) gnome-session empfiehlt gnome-session-fallback
41) gnome-shell empfiehlt gnome-contacts
42) gnome-shell empfiehlt gnome-session-fallback
43) gnumeric empfiehlt evince (>= 0.9.0) | evince-gtk (>= 0.9.0)
44) nautilus empfiehlt gnome-sushi


Diese Lösung akzeptieren? [Y/n/q/?] q
Alle Anstrengungen, diese Abhàngigkeiten aufzulösen, aufgegeben.
Abbruch.

Nun, gnome-sushi-common scheint wohl tatsàchlich veraltet und nutzlos zu
sein, aber wenn ich das entfernen will, will er auch gleich gnome-sushi
und den ganzen oben erwàhnten Rest wegputzen. Dasselbe Problem, wenn ich
mal die Entfernung von libcogl5 anrege. Wo könnte ich da ansetzen, um
weiterzukommen?

Ich hab ansonsten drei andere Rechner (amd64 wie i386) auch auf Wheezy
und keine solchen Update-Probleme.


Grüsse

Patrick
 

Lesen sie die antworten

#1 Dirk Thierbach
13/07/2012 - 09:34 | Warnen spam
Patrick Rudin wrote:
Ich habe hier einen àlteren Drittrechner, auf dem ich Wheezy schon
einige Wochen nicht mehr aktualisiert habe.



Wenn's nur einige Wochen sind: Bei Wheezy/testing koennen die
Abhaengigkeiten schon mal temporaer nicht so hunderprozentig hinhauen
sein. Manchmal merken das die Maintainer, und nach einiger Zeit geht
es wieder.

Nun scheint sich da irgendwas zu blockieren: [...]

Nun, gnome-sushi-common scheint wohl tatsàchlich veraltet und nutzlos zu
sein, aber wenn ich das entfernen will, will er auch gleich gnome-sushi
und den ganzen oben erwàhnten Rest wegputzen. Dasselbe Problem, wenn ich
mal die Entfernung von libcogl5 anrege. Wo könnte ich da ansetzen, um
weiterzukommen?



Generell: aptitude im UI-Modus benutzen, die verschiedenen Vorschlaege
durchgehen (der erste taugt meistens nicht, die vernuenftigen sind
eher die hinteren, wo Pakete upgegradet statt geloescht werden).

Wenn das nichts hilft: Die Vorschlaege ignorieren, sich mit 'b' zu den
Problempaketen durchhangeln, die Pakete dann von Hand fuer "upgrade"
markieren bzw. sich das Problem erstmal genau anschauen. Ich hatte
schon ein paar mal "Platzhalter"-Pakete, die man dann entfernen muss,
damit das richtige "neue" Ersatzpaket installiert wird.

Wenn das nichts hilft: Versuchen, das Problem zu isolieren und zu verstehen.

- Dirk

Ähnliche fragen