Abhaengigkeitsprobleme in Wheezy

10/05/2012 - 05:09 von Patrick Rudin | Report spam
Ich hab seit Jahren zum ersten Mal Paket-Abhàngigkeitsprobleme mit
Aptitude Upgrade (Debian Wheezy):

Paketlisten werden gelesen...
Abhàngigkeitsbaum wird aufgebaut...
Statusinformationen werden eingelesen...
Lesen der erweiterten Statusinformationen...
Initialisieren des Paketstatus'...
Die folgenden teilweise installierten Pakete werden konfiguriert:
baobab eog fontconfig fontconfig-config gedit gedit-plugins
gir1.2-gtk-3.0 gir1.2-gucharmap-2.90 gir1.2-javascriptcoregtk-3.0
gir1.2-panelapplet-4.0 gir1.2-pango-1.0 gir1.2-vte-2.90 gir1.2-webkit-3.0
gnome-panel gnome-power-manager gnome-system-monitor
gnome-themes-standard gucharmap libcairo-gobject2 libcairo2
libfontconfig1 libgail-3-0 libgnome-desktop-3-2 libgtk-3-0 libgtk-3-bin
libgtk2.0-cil libgtkmm-3.0-1 libgucharmap-2-90-7 libnautilus-extension1a
libpanel-applet-4-0 libpango1.0-0 libvte-2.90-9 libwebkitgtk-1.0-0
libwebkitgtk-3.0-0 libwxgtk2.8-0 nautilus python-wxgtk2.8
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusàtzlich installiert, 0 werden entfernt und 0
nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden
0 B zusàtzlich belegt sein.
fontconfig-config (2.9.0-3) wird eingerichtet ...^M
rmdir: konnte „/var/lib/defoma/fontconfig.d/“ nicht entfernen: Das
Verzeichnis ist nicht leer^M
dpkg: Fehler beim Bearbeiten von fontconfig-config (--configure):^M
Unterprozess installiertes post-installation-Skript gab den Fehlerwert
1 zurück^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libfontconfig1:amd64:^M
libfontconfig1:amd64 hàngt ab von fontconfig-config (= 2.9.0-3); aber:^M
Paket fontconfig-config ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libfontconfig1:amd64 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von libcairo2:amd64:^M
libcairo2:amd64 hàngt ab von libfontconfig1 (>= 2.8.0); aber:^M
Paket libfontconfig1:amd64 ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libcairo2:amd64 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libcairo-gobject2:amd64:^M
libcairo-gobject2:amd64 hàngt ab von libcairo2 (>= 1.10.0); aber:^M
Paket libcairo2:amd64 ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libcairo-gobject2:amd64 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von fontconfig:^M
fontconfig hàngt ab von libfontconfig1 (>= 2.9.0); aber:^M
Paket libfontconfig1:amd64 ist noch nicht konfiguriert.^M
fontconfig hàngt ab von fontconfig-config; aber:^M
Paket fontconfig-config ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von fontconfig (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libpango1.0-0:amd64:^M
libpango1.0-0:amd64 hàngt ab von libcairo2 (>= 1.8.10-3); aber:^M
Paket libcairo2:amd64 ist noch nicht konfiguriert.^M
libpango1.0-0:amd64 hàngt ab von libfontconfig1 (>= 2.8.0); aber:^M
Paket libfontconfig1:amd64 ist noch nicht konfiguriert.^M
libpango1.0-0:amd64 hàngt ab von fontconfig (>= 2.1.91); aber:^M
Paket fontconfig ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libpango1.0-0:amd64 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von libgtk-3-0:amd64:^M
libgtk-3-0:amd64 hàngt ab von libcairo-gobject2 (>= 1.10.0); aber:^M
Paket libcairo-gobject2:amd64 ist noch nicht konfiguriert.^M
libgtk-3-0:amd64 hàngt ab von libcairo2 (>= 1.10.0); aber:^M
Paket libcairo2:amd64 ist noch nicht konfiguriert.^M
libgtk-3-0:amd64 hàngt ab von libfontconfig1 (>= 2.8.0); aber:^M
Paket libfontconfig1:amd64 ist noch nicht konfiguriert.^M
libgtk-3-0:amd64 hàngt ab von libpango1.0-0 (>= 1.30.0); aber:^M
Paket libpango1.0-0:amd64 ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libgtk-3-0:amd64 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libgnome-desktop-3-2:^M
libgnome-desktop-3-2 hàngt ab von libcairo2 (>= 1.2.4); aber:^M
Paket libcairo2:amd64 ist noch nicht konfiguriert.^M
libgnome-desktop-3-2 hàngt ab von libgtk-3-0 (>= 3.3.16); aber:^M
Paket libgtk-3-0:amd64 ist noch nicht konfiguriert.^M
dpkg: Fehler beim Bearbeiten von libgnome-desktop-3-2 (--configure):^M
Abhàngigkeitsprobleme - verbleibt unkonfiguriert^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libpanel-applet-4-0:^M
libpanel-applet-4-0 hàngt ab von libcairo-gobject2 (>= 1.10.0); aber:^M
Paket libcairo-gobject2:amd64 ist noch nicht konfiguriert.^M
libpanel-applet-4-0 hàngt ab von libcairo2 (>= 1.10.0); aber:^M
Paket libcairo2:amd64 ist noch nicht konfiguriert.^M
libpanel-applet-4-0 hàngt ab von libgtk-3-0 (>= 3.3.8); aber:^M
Paket libgtk-3-0:amd64 ist noch nicht konfiguriert.^M
libpanel-applet-4-0 hàngt ab von libpango1.0-0 (>= 1.15.4); aber:^M
Paket libpango1.0-0:amd64 ist noch nicht konfiguriert.^M


Und so geht das dann noch eine ganze Weile weiter. Mir scheint das ein
Zirkelschluss zu sein, wo könnte ich da ansetzen?


dpkg -C
Die folgenden Pakete wurden entpackt, aber noch nicht konfiguriert.
Sie müssen mit dpkg --configure oder dem Konfigurations-Menüeintrag in
dselect konfiguriert werden, damit sie ordnungsgemàß funktionieren:
libpanel-applet-4-0 library for GNOME Panel applets
libwxgtk2.8-0:amd64 wxWidgets Cross-platform C++ GUI toolkit (GTK+
runtime)
libcairo2:amd64 The Cairo 2D vector graphics library
eog Eye of GNOME graphics viewer program
libwebkitgtk-1.0-0 Web content engine library for GTK+
gnome-system-monitor Process viewer and system resource monitor for GNOME
libgtk2.0-cil CLI binding for the GTK+ toolkit 2.12
fontconfig generic font configuration library - support binaries
gnome-themes-standard Standard gnome themes
libgail-3-0:amd64 GNOME Accessibility Implementation Library --
shared libr
python-wxgtk2.8 wxWidgets Cross-platform C++ GUI toolkit
(wxPython bindin
gnome-panel launcher and docking facility for GNOME
gedit official text editor of the GNOME desktop environment
libwebkitgtk-3.0-0 Web content engine library for GTK+
libfontconfig1:amd64 generic font configuration library - runtime
gir1.2-javascriptcoregtk-3.0 GObject introspection data for the
GTK+-based Jav
gir1.2-webkit-3.0 GObject introspection data for the WebKit library
libvte-2.90-9 Terminal emulator widget for GTK+ 3.0 - runtime files
gedit-plugins set of plugins for gedit
libcairo-gobject2:amd64 The Cairo 2D vector graphics library (GObject
library)
libgtk-3-0:amd64 GTK+ graphical user interface library
libpango1.0-0:amd64 Layout and rendering of internationalized text
gir1.2-pango-1.0 Layout and rendering of internationalized text -
gir bind
libnautilus-extension1a libraries for nautilus components - runtime
version
gir1.2-panelapplet-4.0 GObject introspection for the GNOME Panel
Applet librar
gucharmap Unicode character picker and font browser
libgtk-3-bin programs for the GTK+ graphical user interface
library
nautilus file manager and graphical shell for GNOME
baobab GNOME disk usage analyzer
libgtkmm-3.0-1:amd64 C++ wrappers for GTK+ (shared libraries)
gir1.2-gtk-3.0 GTK+ graphical user interface library -- gir bindings
gir1.2-vte-2.90 GObject introspection data for the VTE library
libgucharmap-2-90-7 Unicode browser widget library (shared library)
gir1.2-gucharmap-2.90 GObject introspection data for the Unicode
browser widge
libgnome-desktop-3-2 Utility library for loading .desktop files -
runtime file
gnome-power-manager power management tool for the GNOME desktop

Die folgenden Pakete sind nur halb konfiguriert, wahrscheinlich durch
Probleme wàhrend der ersten Konfiguration. Die Konfiguration sollte mit
dpkg --configure <Paket> oder mit dem Konfigurations-Menüeintrag in
dselect erneut versucht werden:
fontconfig-config generic font configuration library - configuration

The following packages are missing the md5sums control file in the
database, they need to be reinstalled:
module-init-tools transitional dummy package (module-init-tools to
kmod)
gcj-4.6-jre Java runtime environment using GIJ/classpath
bogofilter fast Bayesian spam filter (dummy package)
gcj-4.4-jre Java runtime environment using GIJ/classpath
doc-debian Debian Project documentation and other documents
cups-driver-gutenprint transitional dummy package for gutenprint
printer drive
gcj-jre Java runtime environment using GIJ/classpath
g++ GNU C++ compiler
gcj-jre-headless Java runtime environment using GIJ/classpath
(headless ve
libaudio2:amd64 Network Audio System - shared libraries
default-jre Standard Java or Java compatible Runtime
binutils GNU assembler, linker and binary utilities


Oder muss ich einfach warten, bis beim nàchsten Lauf eine benötigte
Abhàngigkeit nach Testing rüberlàubt, und dann löst sich alles in
Wohlgefallen auf?

eog zieht derzeit den ganzen Rechner in den Abgrund, wenn man es startet


Grüsse

Patrick
 

Lesen sie die antworten

#1 E. Braun
10/05/2012 - 09:09 | Warnen spam
Patrick Rudin wrote:
Ich hab seit Jahren zum ersten Mal Paket-Abhàngigkeitsprobleme mit
Aptitude Upgrade (Debian Wheezy):


[...]
fontconfig-config (2.9.0-3) wird eingerichtet ...^M
rmdir: konnte „/var/lib/defoma/fontconfig.d/“ nicht entfernen: Das
Verzeichnis ist nicht leer^M
dpkg: Fehler beim Bearbeiten von fontconfig-config (--configure):^M
Unterprozess installiertes post-installation-Skript gab den Fehlerwert
1 zurück^M
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libfontconfig1:amd64:^M



Das ist der ausschlaggebende Fehler. Schaffe das Verzeichnis
/var/lib/defoma/fontconfig.d/
aus dem Weg, danach müßte alles gehen.


Gruß, Erik

Ähnliche fragen