Forums Neueste Beiträge
 

Acc 2010 - Acc2007

01/08/2013 - 12:07 von Sigbert Helle | Report spam
Hallo Leute,

und das nàchste Problem: Ich hab hier ne Datenbank, die ich schon seit
Acc 1.1 oder so immer weiter entwickelt habe, gestern mit eurer Hilfe
anscheinend das letzte Problem gelöst (Filter entfernen ...) und nun
wollte ich sie freude strahlend heute Morgen einem Bekannten auf seinen
Laptop packen - und nix geht mehr.
Zuletzt entwickelt mit Acc2010 unter WinXP, kopiert auf PC mit Acc2007
auch WinXP.
Standard-Schalter wie dieser funktionieren nicht - nicht mal ne
Fehlermeldung:
Sub neuAut_Click()
On Error GoTo Err_neuAut_Click

Dim stDocName As String
Dim stLinkCriteria As String

stDocName = "frmAut"
DoCmd.OpenForm stDocName, , , stLinkCriteria

Exit_neuAut_Click:
Exit Sub

Err_neuAut_Click:
MsgBox Err.Description
Resume Exit_neuAut_Click

End Sub

==Wenn ich das Formular frmAut in der DaBa-Oberflàche anklicke öffnet es sich.
Der VBA-Editor làsst sichg auch öffnen, bei den Verweisen stehen keine
Fehlermeldungen.
Allerdings fàllt mir jetzt ein, dass der Verweis auf die MS Acc 14.0
Object Library doch eigentlich unter Acc2007 nicht funktionieren dürfte
- war aber nicht als fehlerhaft markiert.
Mein Problem ist auch, dass der andere PC (Notebook) jetzt wieder
unterwegs ist in den Süden Deutschlands.

Bin ziemlich hilflos ...

Gruß
Sigbert
 

Lesen sie die antworten

#1 Peter Doering
01/08/2013 - 12:56 | Warnen spam
Hallo,

Vorweg: Du solltest entweder deine Entwicklungsumgebung auf die niedrigste
Version umstellen, die du im Feld unterstuetzen musst, oder alle im Feld
auf deine Version hochziehen.

Sigbert Helle wrote:

[...] und nun
wollte ich sie freude strahlend heute Morgen einem Bekannten auf seinen
Laptop packen - und nix geht mehr.
Zuletzt entwickelt mit Acc2010 unter WinXP, kopiert auf PC mit Acc2007
auch WinXP.
Standard-Schalter wie dieser funktionieren nicht - nicht mal ne
Fehlermeldung:



Wie aeussert sich dann das "funktionieren nicht"? Was passiert (nicht)?

==> Wenn ich das Formular frmAut in der DaBa-Oberflàche anklicke öffnet es sich.
Der VBA-Editor làsst sichg auch öffnen, bei den Verweisen stehen keine
Fehlermeldungen.
Allerdings fàllt mir jetzt ein, dass der Verweis auf die MS Acc 14.0
Object Library doch eigentlich unter Acc2007 nicht funktionieren dürfte
- war aber nicht als fehlerhaft markiert.



Der ist in A07 auch nicht vorhanden. Du musst den Verweis auf dem
Zielsystem manuell auf MS Acc 12.0 aendern, d.h. 14 wegklicken und ueber
Browse zu 12.0 navigieren und hinzufuegen.

Gruss - Peter

Mitglied im http://www.dbdev.org
FAQ: http://www.donkarl.com

Ähnliche fragen