Access 2000: Unnötige Parameterabfrage bei Unterbericht

21/04/2010 - 12:55 von Raimund Gryszik | Report spam
Hallo Profis, hier ein kleines Problem, umstàndlich zu formulieren:

ich habe einen Hauptbericht, der auf einer Abfrage basiert, die zwei
Tabellen in Beziehung setzt. Dabei liefert eine Tabelle einen eindeutigen
Schlüssel für die Resultatmenge. Der Hauptbericht ist außerdem nach einem
anderen Kriterium gruppiert.

Dazu habe ich einen Unterbericht, dessen Datenherkunft exakt die selbe
Abfrage ist wie die des Hauptberichtes. Damit der Unterbericht nur die
passenden Datensàtze aus der Gruppe liefert, habe ich »Verknüfen
von/Verknüpfen nach« auf den oben erwàhnten Primary Key gesetzt.

Das funktioniert auch alles ganz prima. D.h., der Unterbericht liefert exakt
die richtigen Daten.

Nur: vorher kommt immer eine Parameterabfrage (diese kleine Dialogbox
»Parameterwerte eingeben«. Angefragt wird kein Feldname, sondern der
Tabellenname).

Es spielt auch keine Rolle, was der User in diese Parameterabfrage eingibt,
er kann das Feld auch leer lassen und einfach OK klicken. Trotzdem liefert
der Unterbericht immer die richtigen Daten.

Wie bekomme ich diese làstige Anfrage weg?

Danke für Tipps

Raimund Gryszik, Berlin
 

Lesen sie die antworten

#1 Raimund Gryszik
21/04/2010 - 13:22 | Warnen spam
Hi,

habe durch Rumsuchen im Web unerwartet einen Workaround gefunden, der
funktioniert: Vergabe von (zwei verschiedenen) Aliasnamen für die verknüpften
Felder in den beiden Abfragen. Jetzt unterbleibt die unnötige Nachfrage.

Raimund

Ähnliche fragen