Access Formular neue id bei gleicher Bezeichnung

07/11/2012 - 10:49 von Hubert Holler | Report spam
Ich verwende eine Access mdb Datenbank wo ich ein Formular mit einem
Unterformulare erstellt habe.
Die Datenbank holt sich die Tabellen über odbc von einer mysql Datenbank.

Im Hauptformular gebe ich die Artikelbezeichnung ein.
Im ersten Unterformular wàhle ich die Kategorie aus.

Wenn ich einen Artikel mit einer neuen Bezeichnung eingebe bekomme ich
wie es soll eine neue items_id. Wenn ich aber einen neuen Artikel mit
einer Bezeichnung eingebe, die ich schon mal vergeben habe, bekomme ich
immer die erste items_id von dem Artikel mit der selben Bezeichnung. Es
soll aber eine neue items_id kommen.

Wenn ich aus dem Artikel aussteige und in der Tabelle suche, hat er die
selbe Bezeichnung mit einer neuen items_id angelegt.

D.h. wenn ich einen Artikel mit einer Bezeichnung anlege, die ich schon
verwendet habe, muss ich aus dem Artikelformular aussteigen. Dann den
neuen Artikel suchen und erst dann kann ich weiter eingeben.

Hoffe da kann mir jemand weiterhelfen, wo das Problem liegen könnte,
bzw. wie ich dieses beheben könnte.

Vielen Dank für jede Antwort
 

Lesen sie die antworten

#1 Karl Donaubauer
07/11/2012 - 22:04 | Warnen spam
Hubert Holler wrote:
Ich verwende eine Access mdb Datenbank wo ich ein Formular mit einem
Unterformulare erstellt habe.
Die Datenbank holt sich die Tabellen über odbc von einer mysql
Datenbank.
Im Hauptformular gebe ich die Artikelbezeichnung ein.
Im ersten Unterformular wàhle ich die Kategorie aus.

Wenn ich einen Artikel mit einer neuen Bezeichnung eingebe bekomme ich
wie es soll eine neue items_id. Wenn ich aber einen neuen Artikel mit
einer Bezeichnung eingebe, die ich schon mal vergeben habe, bekomme
ich immer die erste items_id von dem Artikel mit der selben
Bezeichnung. Es soll aber eine neue items_id kommen.

Wenn ich aus dem Artikel aussteige und in der Tabelle suche, hat er
die selbe Bezeichnung mit einer neuen items_id angelegt.

D.h. wenn ich einen Artikel mit einer Bezeichnung anlege, die ich
schon verwendet habe, muss ich aus dem Artikelformular aussteigen.
Dann den neuen Artikel suchen und erst dann kann ich weiter eingeben.



Du solltest noch ein paar Dinge nàher erlàutern:

Was genau meinst du mit "eingebe"?
Schreibst du einfach in einen neuen Datensatz im Hauptformular oder
warum/wodurch bekommst du eine "neue items_id"?

Was ist eine "items_id"?
Ein Auto_Increment-Feld in der Artikeltabelle?

Schreibst du die Bezeichnung vielleicht in ein Kombinationsfeld samt
Code dahinter oder dergl.?

Hat das ganze etwas mit der Konstellation Haupt- und Unterformular
zu tun oder hast du das nur zwecks Umfeld erwàhnt?

Servus
Karl
********
Access-FAQ: www.donkarl.com

Ähnliche fragen