Access - Probleme Tabellenerstellungsabfrage / Tabellen mit SQL-Server

11/12/2008 - 14:17 von Peter Piry | Report spam
Hallo,

kennt jemand von euch folgendes Problem.

Ich habe eine Access-Datenbank, in der die meisten Tabellen verknüpfte Tabellen auf einen SQL-Server sind - aus 2 verschiedenen
Datenbanken.

Sobald ich eine Tabellenerstellungsabfrage (lokale Tabelle wird erstellt) starte, verliert Access die Verknüpfung zu einer der
beiden SQL-Datenbanken. beim Aufruf von allen diesen Tabellen kommt die Fehlermeldung "Could not execute query; could not find
linked table.

[Microsoft][ODBC SQL Server Driver][SQL Server]Ungültiger Objektname 'dbo.MAPos'. (#208)"

Woran kann das liegen?

Wenn ich die Query der Tabellenerstellungsabfrage nur so ausführe, funktioniert alles ganz normal.

lg
Peter
 

Lesen sie die antworten

#1 Peter Doering
11/12/2008 - 14:57 | Warnen spam
Hallo,

Peter Piry wrote:

Ich habe eine Access-Datenbank, in der die meisten Tabellen verknüpfte
Tabellen auf einen SQL-Server sind - aus 2 verschiedenen Datenbanken.

Sobald ich eine Tabellenerstellungsabfrage (lokale Tabelle wird
erstellt) starte, verliert Access die Verknüpfung zu einer der beiden
SQL-Datenbanken. beim Aufruf von allen diesen Tabellen kommt die
Fehlermeldung "Could not execute query; could not find linked table.

[Microsoft][ODBC SQL Server Driver][SQL Server]Ungültiger Objektname
'dbo.MAPos'. (#208)"

Woran kann das liegen?

Wenn ich die Query der Tabellenerstellungsabfrage nur so ausführe,
funktioniert alles ganz normal.



Definiere "nur so", inwiefern unterscheidet es sich zum oben beschriebenen
Fall? Wie sieht die Abfrage aus, wie der Connectstring? Hast du ein Objekt
mit Namen dbo.MAPos?

Gruss - Peter

Mitglied im http://www.dbdev.org
FAQ: http://www.donkarl.com

Ähnliche fragen