ActiveX Steuerelemente

18/10/2008 - 10:47 von Lothar Niefind | Report spam
Hallo!
Nachdem ich von Outlook 2003 auf 2007 gewechselt bin, funktioniert das
Einfügen eines Outlook View Control in ein Formular nicht mehr. Es erscheint
die Meldung "in diesem Steuerelement befindet sich kein Objekt". In den
Verweisen meiner Access 2007 Anwendung ist ist das View control allerdings zu
sehen. Weiß vielleicht jemand, welches der Grund sein könnte? Auf der Website
von Gunter Avenius steht zu lesen, daß man das Steuerelement est (.ocx)
registrieren müsse. Von solchem ocx finde ich freilich keine Spur auf meinem
Rechner. Gestern hatte ein freundlicher Mensch vom MS Support dasselbe
Ergebnis (bzw. Nicht-Ergebnis) wie ich, wollte mir dann aber nicht
weiterhelfen und mich stattdessen an den Professional Support 299 Euros +
Mwst. bezahlen lassen (was ich dann doch wieder nicht nett fand, aber es sind
dort wohl auch nur Menschen, die tun müssen, was man ihnen sagt).

Bei der ActiveX-Auflistung (im Einfügen-Menü) sind noch eine Menge weiterer
reizender Outlook-Elemente genannt, doch diese verweigern sich vollkommen
(Meldung: "Der OLE-Server ist nicht registriert und muß neu installiert
werden" - aber wovon/woher?)

Herzlichen Dank für jeden Tipp!
Lothar Niefind
 

Lesen sie die antworten

#1 Jens Schilling
18/10/2008 - 11:48 | Warnen spam
Hallo, Lothar

Lothar Niefind wrote:
Hallo!
Nachdem ich von Outlook 2003 auf 2007 gewechselt bin, funktioniert das
Einfügen eines Outlook View Control in ein Formular nicht mehr. Es
erscheint die Meldung "in diesem Steuerelement befindet sich kein
Objekt". In den Verweisen meiner Access 2007 Anwendung ist ist das
View control allerdings zu sehen. Weiß vielleicht jemand, welches der
Grund sein könnte? Auf der Website von Gunter Avenius steht zu lesen,
daß man das Steuerelement est (.ocx) registrieren müsse.


[Snip]

Wie das geht, steht ja auch bei Gunter:

http://www.avenius.de/index.php?Support:ActiveX_FAQ:2

Bei der ActiveX-Auflistung (im Einfügen-Menü) sind noch eine Menge
weiterer reizender Outlook-Elemente genannt, doch diese verweigern
sich vollkommen (Meldung: "Der OLE-Server ist nicht registriert und
muß neu installiert werden" - aber wovon/woher?)



Hier folgt üblichweise der Link zur FAQ 7.20 OLE-Server nicht registriert
( www.donkarl.com?FAQ7.20 )

Allerdings ist das Problem mit dem Outlook View Control (OVC) bekannt; ich
musste mir diesen Link (
http://www.devnewsgroups.net/group/...62877.aspx )
erst selbst noch mal ergooglen; ich hatte nur in Erinnerung, es schon mal
gelesen zu haben.

Outlook-MVP Sue Mosher beendet den Thread mit dem Satz:

"I just found out that the problem with using the OVC on an Access 2007 form
is a known issue, one with no workaround yet."

Das war der Stand Mai 2007 - aber Sascha hat hier doch einen Workaround
beschreiben können, der Dir vielleicht auch helfen kann :

http://groups.google.com/group/micr...8371ab24dc


Gruss
Jens

Ähnliche fragen