Addieren, solange Referenzzelle leer ist

19/08/2013 - 21:38 von post | Report spam
Moin.

Vorgegeben ist eine zu bezahlende Geldschuld. Der Schuldner darf tilgen,
wann immer er Lust hat. Die Geldschuld wird monatlich verzinst.
Zahlungen werden immer am Monatsersten verrechnet. Zur Berechnung der
Anrechnung der Zahlungen auf Zins und Tilgung gibt es eine Tabelle mit
folgendem Aufbau:

Spalte A enthàlt das Datum des Beginns der jeweiligen monatlichen
Zinsperiode. Spalte B enthàlt die jeweils seit dem vorangegangenen
Zahlungstermin aufgelaufenen Zinsen. In Spalte C wird die in der
jeweiligen Periode tatsàchlich gezahlte Rückzahlungsrate eingetragen. In
Spalte D wird angezeigt, welcher Betrag der Rückzahlungsrate auf die
Zinsen angerechnet wird. In Spalte E wird angezeigt, welcher Betrag auf
die Tilgung angerechnet wird. Und Spalte F enthàlt die Restschuld.

Ich bekomme die Formel für die Zellen in der Spalte D nicht hin. Diese
müsste in Worten gesprochen folgendermaßen lauten:

Schau Dir die Zelle in Spalte C in der aktuellen Zeile an. Wenn dieser
Wert leer ist, dann trage in der Zelle der Spalte D eine Null ein. Wenn
der Wert in der Zelle C der aktuellen Zeile nicht leer ist, dann addiere
zum Wert in der Zelle der Spalte B alle Werte in den vorangehenden
Zellen der Spalte B, solange die jeweilige Zelle in Spalte C leer ist.
Ist die Summe dieser Addition größer als der Wert in Spalte C, dann
trage in Spalte D den Wert aus der Zelle in Spalte C ein, andernfalls
die Summe dieser Addition der relevanten Zellen aus Spalte B.

Wie muss die Formel lauten?

Danke im Voraus für Eure Unterstützung!

Gruß. Friedrich
http://www.rafv.de
post (at) vatolin (punkt) de
 

Lesen sie die antworten

#1 Claus Busch
19/08/2013 - 21:46 | Warnen spam
Hallo Friedrich,

Am Mon, 19 Aug 2013 21:38:33 +0200 schrieb Friedrich Vosberg:

Schau Dir die Zelle in Spalte C in der aktuellen Zeile an. Wenn dieser
Wert leer ist, dann trage in der Zelle der Spalte D eine Null ein. Wenn
der Wert in der Zelle C der aktuellen Zeile nicht leer ist, dann addiere
zum Wert in der Zelle der Spalte B alle Werte in den vorangehenden
Zellen der Spalte B, solange die jeweilige Zelle in Spalte C leer ist.
Ist die Summe dieser Addition größer als der Wert in Spalte C, dann
trage in Spalte D den Wert aus der Zelle in Spalte C ein, andernfalls
die Summe dieser Addition der relevanten Zellen aus Spalte B.



probiere es mal in D1 mit:
=SUMME($B$1:B1)*(C1>0)
und runter ziehen


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen