:-) *** Addition von nur bestimmten Zellen an Hand einer Variablen

13/09/2007 - 16:54 von Ingo | Report spam
Wie kann ich eine Funktion erstellen, die es ermöglicht nur bestimmte Zellen
in einer Tabelle zu addieren. Dabei ist es von einer Variablen abhàngig, ob
eine Zelle addiert werden soll oder nicht.

Ich möchte zeile A1-A6 addieren. Vielleicht aber auch nur Zeile A1-A4,
vielleicht aber auch A-A31 usw. Das hàngt davon ab, ob im Feld B1 eine 4,
eine 6, eine 31 oder eine andere beliebige Zahl steht.

Wie kann ich es programmieren, dass die Zahl in Feld B1 abgegriffen wird und
dann genau diese anzahl an Zellen addiert wird?

Vielen Dank für Hilfe!!!!!!
ingo :-)))
 

Lesen sie die antworten

#1 Claus Busch
13/09/2007 - 16:55 | Warnen spam
Hallo Ingo,

Am Thu, 13 Sep 2007 07:54:03 -0700 schrieb Ingo:

Wie kann ich eine Funktion erstellen, die es ermöglicht nur bestimmte Zellen
in einer Tabelle zu addieren. Dabei ist es von einer Variablen abhàngig, ob
eine Zelle addiert werden soll oder nicht.

Ich möchte zeile A1-A6 addieren. Vielleicht aber auch nur Zeile A1-A4,
vielleicht aber auch A-A31 usw. Das hàngt davon ab, ob im Feld B1 eine 4,
eine 6, eine 31 oder eine andere beliebige Zahl steht.

Wie kann ich es programmieren, dass die Zahl in Feld B1 abgegriffen wird und
dann genau diese anzahl an Zellen addiert wird?



probiers mal so:
=SUMME(A1:INDIREKT("A"&B1))


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen