Forums Neueste Beiträge
 

Adresse statt Wert vom SVERWEIS

25/04/2008 - 16:07 von Thomas Gahler | Report spam
Hallo zusammen

Kann mir jemand helfen. Ich habe da so eine ziemlich verzwickte
Angelegenheit.

Ich habe eine Tabelle:

| Jan. | 10 |
| Feb. | 20 |
| Màr. | 30 |
| Apr. | 1 |
| Mai. | 13 |
| Jun. | 31 |
| Jul. | 15 |
| Aug. | 10 |

Einen Wert -> Apr.
Ein Offset -> 3

jetzt sollte ich mittels SVERWEIS in die Tabelle gehen

dann bekomme ich zum Wert 'Apr.' die Zahl 1 zurück, ich benötige jedoch den
Wert der Zelle "B4", damit ich anschliessend mit dem Offset 3
die Zahlen 1, 30, 20 bekommen und daraus den MITTELWERT berechnen kann
(Resultat 17)



- Mit welcher Funktion (keine Makros) komme ich an die Zelle "B4"?

- Gehe ich richtig, wenn ich anschliessend den Bereich mittels
BEREICH.VERSCHIEBEN bestimmen will um den MITTELWERT zu berechnen?


Besten Dank für alle Tipps.




Thomas Gahler
MVP für WordVBA
Co-Autor von »Microsoft Word-Programmierung.
Das Handbuch« (MS Press)


- Windows XP (SP2), Office XP (SP3)
 

Lesen sie die antworten

#1 Bernd P
25/04/2008 - 16:26 | Warnen spam
Hallo Thomas,

VERGLEICH ist wohl das was Du suchst.

BEREICH.VERSCHIEBEN geht danach zwar auch, aber INDEX ist besser weil
es nicht volatil ist (wird nicht bei jedem F9 neu ausgewertet):

=AVERAGE(INDEX(A1:B12,MATCH("Apr",A1:A12,)-2,2):INDEX(A1:B12,MATCH("Apr",A1:A12,),
2))

Zu deutsch:
=MITTELWERT(INDEX(A1:B12;VERGLEICH("Apr";A1:A12;)-2;2):INDEX(A1:B12;VERGLEICH("Apr";A1:A12;);
2))

Viele Grüße,
Bernd

Ähnliche fragen