Aiport Express von anderem Subnetz ansprechen?

31/05/2008 - 19:53 von Sebastian Kaps | Report spam
Hi!

Ich habe mir eine Airport Express Station gekauft, um Musik auf meine
Hifi-Anlage zu streamen. Folgendes Netzwerksetup ist gegeben:

Airport Express ((())) Access Point ((())) Linux RechnerArbeitsplatz

((())) = WLAN-Strecke, 192.168.10.0/24 Netz
= Ethernet, 192.168.1.0/24 Netz

Der Airport Express ist als Client eingerichtet und am Access Point
angemeldet. Der Linux-Rechner macht DNS, DHCP, Avahi (Bonjour) usw. -
alles was an Serverdiensten zu Hause halt gebraucht wird.
Wenn ich mit dem Macbook ebenfalls per WLAN "unterwegs" bin, kann ich
den Airport Express konfigurieren und das Streaming vom Notebook zur
Anlage funktioniert einwandfrei.

Vom Arbeitsplatz aus wird der Airport zwar vom Airport Utility und von
iTunes auch gefunden (anpingbar ist er ebenfalls), aber das Verbinden
mit iTunes klappt nicht. Wenn ich den Airport in iTunes auswàhle,
erscheint eine Art Fortschrittsbalken, der nach ein paar Sekunden wieder
verschwindet, ohne daß die Sound-Ausgabe umgeleitet wàre.
Das Konfigurieren klappt allerdings meistens - manchmal gibt es einen
Timeout, wobei ich auch vom Macbook schon hàufiger Probleme hatte, die
Konfiguration zu laden. Ein Aus-/Einschalten des Airports behebt das
Problem in der Regel.

Hat jemand ein àhnliches Setup am Laufen und kann mir sagen, was bei mir
schief làuft?
Ciao, Sebastian
 

Lesen sie die antworten

#1 Juergen P. Meier
01/06/2008 - 08:48 | Warnen spam
Sebastian Kaps :
Airport Express ((())) Access Point ((())) Linux RechnerArbeitsplatz

((())) = WLAN-Strecke, 192.168.10.0/24 Netz
= Ethernet, 192.168.1.0/24 Netz

Der Airport Express ist als Client eingerichtet und am Access Point
angemeldet. Der Linux-Rechner macht DNS, DHCP, Avahi (Bonjour) usw. -
alles was an Serverdiensten zu Hause halt gebraucht wird.
Wenn ich mit dem Macbook ebenfalls per WLAN "unterwegs" bin, kann ich
den Airport Express konfigurieren und das Streaming vom Notebook zur
Anlage funktioniert einwandfrei.



D.h. der AP ist im "Bridgemode"?

Vom Arbeitsplatz aus wird der Airport zwar vom Airport Utility und von
iTunes auch gefunden (anpingbar ist er ebenfalls), aber das Verbinden
mit iTunes klappt nicht. Wenn ich den Airport in iTunes auswàhle,
erscheint eine Art Fortschrittsbalken, der nach ein paar Sekunden wieder
verschwindet, ohne daß die Sound-Ausgabe umgeleitet wàre.



Was sagt denn das Systemlog? (Utilities/Console.app).

Da du den AE in iTunes siehst, muss mDNS (Bonjour) auf dem
Linuxrechner ja offenbar funktionieren. Routing klappt anscheinend
auch (ping). Hat der Linuxrechner irgendwelche Paketfilterregeln
(iptables) oder helper-module geladen, die stoeren?

Das Konfigurieren klappt allerdings meistens - manchmal gibt es einen
Timeout, wobei ich auch vom Macbook schon hàufiger Probleme hatte, die
Konfiguration zu laden. Ein Aus-/Einschalten des Airports behebt das
Problem in der Regel.



Steht im Systemlog (Console.app) irgendwas passendes dazu?

Hat jemand ein àhnliches Setup am Laufen und kann mir sagen, was bei mir
schief làuft?



Nein.

Aber du kannst dir ja mal wireshark proiberen (entweder ueber Darwinports
falls du diese bereits nutzt, oder alternativ von
http://prdownloads.sourceforge.net/..._Intel.dmg
bzw. wenn das nicht funktioniert oder dir Pakete fehlen:
http://www.finkconsulting.com/page7.php - Es wird jeweils installiertes
X11.app benoetigt (von der Leopard-installatoins-DVD).

Wireshark starten*, als Netzwerkinterface en0 (=Ethernet, WLAN waere
en1) auswaehlen, capture starten, iTunes AE auswaehlen und lied
starten, wireshark capture stoppen und analysieren.

* beim 1. Mal startet Leopard X11 automatisch, da dauert das auch mal
ne halbe Minute...

Juergen
Juergen P. Meier - "This World is about to be Destroyed!"
end
If you think technology can solve your problems you don't understand
technology and you don't understand your problems. (Bruce Schneier)

Ähnliche fragen