AirPort-Problem die 825ste

15/04/2009 - 23:02 von Reindl Wolfgang | Report spam
Hallo,

die Schilderung vonJoachim in MID
<49735073$0$30228$9b4e6d93@newsspool1.arcor-online.net>
ist praktisch wörtlich auf den iMac Alu (Dez.08, X 10.5.6) meiner Mutter
und dessen Verbindung und eben Nichtverbindung zu "seinem" DSL-Router
(SpeedPort W303V der dt. Teledumm) übertragbar.

Derzeit bricht die Verbindung zum Router im 5-Minuten-Rhythmus ab -- und
ist dann nach weiteren 5 Min oder 7 oder 10 plötzlich wieder da - wieder
weg ...

Das AirPort-Menu zeigt neben dem heimischen Netz Dahoam noch 2 weitere
Netzwerke an: EasyBox-xyz und IMPULSNET, alle 3 mit geschlossenem
Vorhàngeschloß hinter dem Menu-Eintrag.

Das IMPULSNET macht genau das, was der Name vermuten làßt: es ist
impulsartig da und wieder weg (zumindest im AirPort-Menu), ca. im
gleichen Rhythmus wechselt der Menu-Eintrag von "AirPort: Aktiviert" zu
"AirPort: Suchen ..." und das Strichradl rotiert - Die Feldstàrkeanzeige
in der Menuzeile bleibt dabei auf Anschlag schwarz. Auch
Systemeinstellungen -> Netzwerk behauptet, AirPort sei verbunden,
wàhrend Safari keine Verbindung ins Netz zustande bringt.

iStumbler erkennt für das eigene Netz die Kanalnummer 13, für die
Easybox 1 und das IMPULNET Kanal 11; KisMAC erkennt zudem, daß die
EasyBox gelegentlich auf Kanal 2, 3 oder 4 wechselt und nach Sekunden
zurück zu 1 geht - und daß das IMPULSNET gelegentlich für ein paar
Sekunden Kanal 13 beansprucht ... Der Störebold ist also hinreichend
identifiziert.
Versteckte Netze hat KisMAC keine entdecken können.
lt. KisMac ist die Signalstàrke
Dahoam > EasyBox >> IMPULSNET


Irgendeine Möglichkeit, für das Netzwerk meiner Mutter einen Funk-Kanal
fix einzustellen, hab' ich bisher weder in den Systemeinstellungen noch
per Web-Interface auf dem Router gefunden.


Der nàchstgelegene mögliche Standort für einen Störsender ist jenseits
einer doppelten Brandmauer + Stahlbetondecke, andere mögliche Standorte
sind deutlich über 50 m und mehrere Mauern entfernt.



AirPort -> Mit anderem Netzwerk verbinden ... -> Netzwerke anzeigen
listet mir nach kurzer Suche
Easybox-xyz
IMPULSNET
Dahoam
in dieser Reihenfolge und mit einem zugesperrten Schloß auf. "Dieses
Netzwerk merken" ist zwar ausgegraut aber angehakt, wenn ich dann auf
Dahoam klicke wird die Checkbox blau unterlegt und das Kennwort (aus dem
Schlüsselbund) eingefügt. Wenn ich für eines der beiden unerwünschten
Netze die Checkbox enthake, dann ist sie auch für Dahoam nicht angehakt.
Irgendeine Möglichkeit, die beiden unerwünschten Netzwerke aus der
Liste zu werfen hab' ich bisher nicht gefunden.

Warum kann man dem Mac nicht schlichtundeinfach mitteilen, er soll
ausschließlich auf das heimische Netz hören und die übrigen Funker
nichteinmal ignorieren? zàfixnoamoi!
In den diversen Unterabteilungen der Systemeinstellung -> Netzwerk sind
die beiden Fremdnetze angehakt und ich kann diese Hakeln genausowenig
dauerhaft entfernen, wie ich die Fremdnetze aus den Listen werfen kann.
Spàtestens beim nàchsten Aufruf sind die Hakeln wieder gesetzt.
Auch aus den "bevorzugten Netzwerken" kann ich die Störnetze nicht
entfernen.

Das gleiche Problem mit der wackligen WLAN-Verbindung hatte ein Gast
meiner Mutter mit seinem winDOS-Laptop, wobei das Gàstezimmer
geringfügig besser zum Router positioniert ist wie der iMac und das
gleiche Problem hab' auch ich mit meinem iBook (G3, weiß, orig. Apple
AirPort-Karte) trotz beinahe optimaler Position zum Router.
Gelöst werden muß das Verbindungsproblem aber vom iMac aus und vor Allem
für den iMac.

Leider bin ich als DAA (d... a... Admin) jtzt wieder weg von Mutters
iMac und kann daher Optimierungsvorschlàge erstmal nicht umsetzen und
auch Rückfragen nicht auf die Schnelle beantworten. Totzdem bin ich
latürnich für sachdienliche Hinweise sehr dankbar.

Wolfgang

p.s. derzeit ist lt. KisMAC das Signal von der EasBox auf 0 mit wenigen
kurzen Spitzen bis 78 dazwischen - dafür hat es sich das Malefitz
IMPULSNET auf Kanal 13 bequem gemacht und sendet mit einem Signal von
fast 70 mit gelegentlichen Einbrüchen auf 0. Dahoam liegt bei ziemlich
konstant 79
 

Lesen sie die antworten

#1 Thomas Kaiser
16/04/2009 - 09:50 | Warnen spam
Reindl Wolfgang schrieb am 15.04.2009 in <news:gs5i1e$ls0$00$
Irgendeine Möglichkeit, für das Netzwerk meiner Mutter einen Funk-Kanal
fix einzustellen, hab' ich bisher weder in den Systemeinstellungen noch
per Web-Interface auf dem Router gefunden.



Hast Du einen Linux-fàhigen Linksys (bspw. WRT54GL [1]) herumliegen? Für
die Kisten gibt es exzellente alternative Firmwares, die sich simpelst
flashen lassen und mit denen

a) sowas geht

b) Material zum Analysieren solcher Probleme bereitsteht

Daß "unsichtbare" Netze wohl nicht hineinspielen, hast Du ja schon per
KisMAC ausschließen können.

Irgendeine Möglichkeit, die beiden unerwünschten Netzwerke aus der
Liste zu werfen hab' ich bisher nicht gefunden.



Naja, was soll das schon bringen? Die Netzwerke werden natürlich
angezeigt, weil sie existieren, also bei der Nutzung des gemeinsamen
Netzwerkmediums (Äther) ggf. Probleme bereiten können. Falls Du -- meist
des guten Gefühls wegen -- Tabularasa machen wolltest, müsstest Du mal
unterhalb /Library/Preferences/SystemConfiguration/ aufràumen. Wenn Du
dort alles löscht, sind auch erstmal sàmtliche Netzwerk-Settings futsch
(abgesehen von im Schlüsselbund gespeicherten WLAN-Passphrases). D.h.
das wàre ein definierter "Start bei Null" oder so.

Ich würde aber eher bei einer Analyse des Problems ansetzen...

Warum kann man dem Mac nicht schlichtundeinfach mitteilen, er soll
ausschließlich auf das heimische Netz hören und die übrigen Funker
nichteinmal ignorieren? zàfixnoamoi!



Das geht, solange auf der physischen Ebene alles ohne Konflikte làuft,
sprich die anderen Netze mit Deinem Wunschnetz nicht in Konflikt
geraten. D.h. wenn bspw. eines der drei Netze auf Kanal 1, eines auf 6
und eines auf 11 herumfunkt, dann stören die sich vom Freqzenzspektrum
her nicht, werden gelistet aber kommen sich nicht in die Quere. Bei Dir
scheint irgendwas anderes zu geschehen (Kanal-Hopping deluxe oder
sowas).

Nachdem das Airport-GUI Vollausschlag meldet und trotzdem keine
"Verbindung" zustande kommt, bringt's eigentlich nur was, auf Mac-Seite
in die relevanten Logs bzw. eben /var/log/system.log zu schauen. Wenn
Dein WAP (das, was Du als Speedport-Router bezeichnest) zu wenig
kooperativ ist, dann lohnt sich ein (testweises) Austauschen gegen
irgendwas Vernünftiges.

Also: WRT bereithalten bzw. gleich mal mit Tomato oder DD-WRT flashen,
in Terminal.app "sudo tail -f /var/log/system.log" in Stellung bringen
(bzw. mittels Konsole.app gucken -- das soll wohl auch gehen), hier
berichten und gleich schon mal mit erweiterten Debug-Techniken vertraut
machen [2].

[1] <http://geizhals.at/deutschland/a172494.html>

[2] Das Folgende taucht auch alles prima als Suchbegriff für weitere
Anleitungen, etc.

/System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport --scan

Airport in Debug-Modus treten (wiederholter Aufruf schaltet den Kram
wieder aus):

sudo /usr/libexec/airportd -d

(Spannend ist dann alles, was sich bzgl. Airport im Log findet.
Extrahieren, um's als Text irgendwo online zu stellen, kann man's
simpel per "grep -i airport /var/log/system.log >/tmp/airport.txt")

Und immer wieder gerne vergessen: Die Funktion der [alt]-Taste. Ich
drück ja schon aus Neugier andauernd drauf und freu mich wie ein
Schnitzel, wenn Buttons auf einmal anders funktionieren, Menüs auf
einmal umfànglicher sind, etc. Ist natürlich bei Airport auch so.
Mit gedrückter [alt]-Taste ins Airport-Menü klicken bringt bisserl
mehr an Infos. Aber alles nix, was auch iStumbler bzw. KisMAC
kontinuierlich liefern könnten.

Ähnliche fragen