Aktive Zelle in Formel

23/01/2014 - 17:01 von Carlos Naplos | Report spam
Hallo

Ich möchte in einer Formel (EXCEL 2007) Bezug auf die Zelle nehmen, in
der die Formel steht.

In einer SVERWEIS-Spalte soll, wenn nichts gefunden wird (WENNFEHLER),
der Wert aus der darüber stehenden Zelle genommen werden.

Funktionieren würde es mit

BEREICH.VERSCHIEBEN(INDIREKT(ZELLE("adresse"));-1;0)

aber geht das nicht einfacher?
Ich habe gelesen INDIREKT sei sehr rechenintensiv; hier kàme es 6 * 365
+ 1-mal vor.

Erlàuterung:

=WENNFEHLER(
SVERWEIS(
B$1+ZEILE()-2;
Tab_09[[Termin]:[Wert]];
SPALTE(Tab_09[Wert])
);
BEREICH.VERSCHIEBEN(INDIREKT(ZELLE("adresse"));-1;0))


In B$1 steht ein Datum (1.1.2009), welches mit JJJJ formatiert die
Überschrift bildet; in B$2 steht 0; in der Tabelle Tab_09 stehen in der
Spalte [Termin] Termine, in der Spalte [Wert] (aufsummierte) Werte.

Tabellen Tab_JJ gibt es für die Jahre ab 2009.

Ein zusammenfassendes Diagramm soll die Werte der Jahre vergleichen.

Mit B$1+ZEILE()-2 erhalte ich den n-ten Tag des Jahres.
Aber die Eintràge in den Tabellen Tab_JJ sind an verschiedenen Tagen.

lg
Carlos
 

Lesen sie die antworten

#1 Claus Busch
23/01/2014 - 17:20 | Warnen spam
Hallo Carlos,

Am Thu, 23 Jan 2014 17:01:35 +0100 schrieb Carlos Naplos:

In B$1 steht ein Datum (1.1.2009), welches mit JJJJ formatiert die
Überschrift bildet; in B$2 steht 0; in der Tabelle Tab_09 stehen in der
Spalte [Termin] Termine, in der Spalte [Wert] (aufsummierte) Werte.

Tabellen Tab_JJ gibt es für die Jahre ab 2009.



wenn deine Datunswerte in Tab_JJ aufsteigend sortiert sind, könntest du
doch mit VERGLEICH arbeiten und als Vergleichstyp 1 einstellen. Gibt es
eine Übereinstimmung bekommst du den korrekten Wert, sonst den nàchst
kleineren:
=INDEX(Tabelle1[[#Alle];[Wert]];VERGLEICH($B$1+ZEILE()-2;Tabelle1[[#Alle];[Termin]];1))


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen