Aktualisierungsabfrag aktualisiert lediglich 1 mal

29/08/2007 - 20:16 von Kai Beutner | Report spam
Hallo @ all,

Ich habe ein kleines Verstàndnis- Problem bei 'AKTUALISIERUNGS ABFRAGEN'
Denn die Aktualisierung funktioniert mit der gleichen Datensatzgruppe nur
einmal.
Veràndern sich die Daten des gleichen Vorganges, noch einmal d.h. im Feld
'Status' steht nicht mehr der wert 'A' sondern 'B', und ich führe die
Aktualisierungs Abfrage mit den Aktualisierten Quelldaten nochmals aus,
bekomme ich die Erfreuliche Rückmeldung das 0 Datensàtze Aktualisiert worden
sind

Nun habe ich Spaßes halber die Daten die bei der ersten Aktualisierung,
aktualisiert worden sind aus dem Datensatz gelöscht.
Und die Abfrage erneut durchlaufen lassen und wieder bekomme ich die Meldung
das 0 Datensàtze Aktualisiert worden sind.

Nehme ich nun eine Datensatzgruppe die noch nie durch die Abfrage gelaufen
sind, funktioniert das ganze 1A ..

Woran könnte das liegen !?
 

Lesen sie die antworten

#1 Kai Beutner
29/08/2007 - 20:20 | Warnen spam
Oki, Wunderbar habe meinen selten dusseligen Fehler gerade gefunden.
Die Beziehungen müssen schon passen ;)

"Kai Beutner" schrieb:

Hallo @ all,

Ich habe ein kleines Verstàndnis- Problem bei 'AKTUALISIERUNGS ABFRAGEN'
Denn die Aktualisierung funktioniert mit der gleichen Datensatzgruppe nur
einmal.
Veràndern sich die Daten des gleichen Vorganges, noch einmal d.h. im Feld
'Status' steht nicht mehr der wert 'A' sondern 'B', und ich führe die
Aktualisierungs Abfrage mit den Aktualisierten Quelldaten nochmals aus,
bekomme ich die Erfreuliche Rückmeldung das 0 Datensàtze Aktualisiert worden
sind

Nun habe ich Spaßes halber die Daten die bei der ersten Aktualisierung,
aktualisiert worden sind aus dem Datensatz gelöscht.
Und die Abfrage erneut durchlaufen lassen und wieder bekomme ich die Meldung
das 0 Datensàtze Aktualisiert worden sind.

Nehme ich nun eine Datensatzgruppe die noch nie durch die Abfrage gelaufen
sind, funktioniert das ganze 1A ..

Woran könnte das liegen !?


Ähnliche fragen