Aktuelles Datum kopieren

11/02/2010 - 14:35 von Klaus Körner | Report spam
Hallöchen,

mein Problem ist folgendes:
Ich möchte in eine Zelle das aktuelle Datum Kopieren und zwar habe ich
es damit versucht:

In Zelle A1 steht: =WENN(D1="erl.";$R$1;"")

Erfolgen soll folgendes:

Wenn ich in Zelle D1 "erl." eintippe, soll aus der Zelle R1 das Datum in
Zelle A1 Kopiert werden, ansonsten bleit die zelle A1 leer.
In Zelle R1 steht die Formel = Heute()

Excel kopiert zwar das heutige Datum, aber am nàchsten Tag wird das
Datum vom Vortag auf den aktuellen Stand gebracht. Und irgend wann steht
in allen Zellen der Spalte A das gleiche Datum und nicht das Datum wo
ich erl. eingetippt habe!

Gibt es eine Möglichkeit, das die Formel durch das Datum überschrieben
wird?
Oder etwas ganz anderes?

Vielen Dank im Voraus

Klaus
 

Lesen sie die antworten

#1 Andreas Killer
11/02/2010 - 15:11 | Warnen spam
Klaus Körner schrieb:

Wenn ich in Zelle D1 "erl." eintippe, soll aus der Zelle R1 das Datum in
Zelle A1 Kopiert werden, ansonsten bleit die zelle A1 leer.
In Zelle R1 steht die Formel = Heute()

Excel kopiert zwar das heutige Datum, aber am nàchsten Tag wird das
Datum vom Vortag auf den aktuellen Stand gebracht. Und irgend wann steht


Mit Formeln geht sowas nicht, da Formeln immer wieder neu berechnet
werden. Aber mit VBA làßt sich das problemlos machen. Das kopieren von
R1 mache ich aber nicht, ich schreib das aktuelle Datum direkt rein.

Der Code muss in das Codemodul der Tabelle, wie's geht steht hier:
http://www.online-excel.de/excel/si....php?fD#s4

Andreas.

Option Explicit
Option Compare Text

Private Sub Worksheet_Change(ByVal Target As Range)
Dim R As Range
'Wurde D1 geàndert?
Set R = Intersect(Target, Range("D1"))
'Wenn nein, dann raus
If R Is Nothing Then Exit Sub
'Ist D1 = "erl."?
If R = "erl." Then
'Ereignisse aus
Application.EnableEvents = False
'A1 = Aktuelles Datum
Range("A1") = Date
'Ereignisse an
Application.EnableEvents = True
End If
End Sub

Ähnliche fragen