alle spalten innerhalb einer Zelle mit einer 2. Tabelle vergleichen

13/04/2011 - 15:47 von Tom | Report spam
Hallo,

ich habe folgendes Problem:

Soll: es gibt in einer Datei 2 Tabellen mit absolut identischen Werten
in den einzelnen Spalten (6 Spalten).

Ist: In der ersten Tabelle sind aktuell 4550 Zeilen, in der 2. Tabelle
sind es 4551 Zeilen.
Eine Zeile ist verschwunden. Ich weiß jetzt nicht, ob nur eine Zeile
fehlt oder ob sogar einige
Daten verstruwwelt wurden.

Wie kann ich die gesamten Zeilen beiden Tabellen vergleichen. Da in
Tabelle 2 ja eine Zeile mehr
ist, muss ja mindestens 1 Zeile hervorgehoben werden, entweder
farblich oder auch durch einkopieren
in eine 3. Tabelle.
Sollten mehrere Daten falsch sein sollten, dann sollten alle
fehlerhaften Zeilen markiert werden.

Wie kann ich dies bewerkstelligen?

Gruß

Tom
 

Lesen sie die antworten

#1 Markus Fuenfrocken
13/04/2011 - 16:11 | Warnen spam
Am 13.04.2011 15:47, schrieb Tom:
Wie kann ich die gesamten Zeilen beiden Tabellen vergleichen. Da in
Tabelle 2 ja eine Zeile mehr
ist, muss ja mindestens 1 Zeile hervorgehoben werden, entweder
farblich oder auch durch einkopieren
in eine 3. Tabelle.
Sollten mehrere Daten falsch sein sollten, dann sollten alle
fehlerhaften Zeilen markiert werden.

Wie kann ich dies bewerkstelligen?


Ich mache sowas mit einer Hilfsspalte in Tabelle1, in der ich über die
Funktion =ZÄHLENWENN(Tabelle2!A:A;A2) und Autoausfüllen zàhlen lasse wie
oft ein Wert in der anderen Tabelle vorkommt. Dann filtere ich nach
dieser Spalte und kann mir mit Wert '0' alle anzeigen lassen die fehlen.

Gruß und HTH?
Markus

Ähnliche fragen