ALT + F4 geht nicht in der Terminal Server Sitzung

08/07/2008 - 09:42 von Le Admin | Report spam
Hallo Leute,

ich habe ein interessantes Phànomen, wenn ich mich mit einer virtuellen
Tastatur eines Drittanbieters (MountFocus) mit einem Terminalserver
verbinde.
Ich möchte mit Hilfe der Tastenkombination "ALT+F4" ein laufendes Programm
beenden. Diese Tastenkombination habe ich in eine virtuelle Tastatur in
einer Schaltflàche hinterlegt.

Die Tastatur mit den programmierten Zeichen und den programmierten
Tastenkombinationen wird mit dem Client gestartet; hier funktionieren noch
sàmtliche einprogrammierten Tastenkombinationen und ein Druck auf die
entsprechenden Tasten produzieren das gewünschte Ergebnis.

Sobald ich jedoch die TerminalServer Session aufhabe, reagiert plötzlich die
einprogrammierte Tastenkombination "ALT+F4" auf der virtuellen Tastatur
nicht mehr !

Kann mir da eventuell jemand helfen?

Liebe Grüße

Ben Harper
 

Lesen sie die antworten

#1 Helmar Schmidt
30/07/2008 - 11:03 | Warnen spam
Hallo,

ich wuerde mal mit den RDP Einstellungen der Tastatur einiges versuchen.
Wenn nicht die korrekten Zeichen in die Terminal Session
weitergeleitet werden koennte das mit den Tastatur Einstellungen
zusammenhaengen.
-> Keyboard Optionenen unter "Local Resources" Tab in MSTSC.EXE (bzw. nach
starten v. mstsc),
nach "On the local computer" (Auf dem lokalen Computer anwenden) aendern
oder umgekehrt.

Gruss,
Helmar



"Le Admin" <leadmin> wrote in message
news:
Hallo Leute,

ich habe ein interessantes Phànomen, wenn ich mich mit einer virtuellen
Tastatur eines Drittanbieters (MountFocus) mit einem Terminalserver
verbinde.
Ich möchte mit Hilfe der Tastenkombination "ALT+F4" ein laufendes Programm
beenden. Diese Tastenkombination habe ich in eine virtuelle Tastatur in
einer Schaltflàche hinterlegt.

Die Tastatur mit den programmierten Zeichen und den programmierten
Tastenkombinationen wird mit dem Client gestartet; hier funktionieren noch
sàmtliche einprogrammierten Tastenkombinationen und ein Druck auf die
entsprechenden Tasten produzieren das gewünschte Ergebnis.

Sobald ich jedoch die TerminalServer Session aufhabe, reagiert plötzlich
die einprogrammierte Tastenkombination "ALT+F4" auf der virtuellen
Tastatur nicht mehr !

Kann mir da eventuell jemand helfen?

Liebe Grüße

Ben Harper

Ähnliche fragen