Alte SCSI-Festplatte geht nicht

16/05/2008 - 14:11 von Alex Schuster | Report spam
Hallo!

Beim Aufràumen meiner Festplatten habe ich eine alte Seagate ST4766N (5.25"
760 MB SCSI) entdeckt. Da die Dinger scheinbar immer noch für > 100 EUR
(bis zu $315 habe ich gesehen) verkauft werden, wollte ich mal testen, ob
sie noch geht. Leider nicht so ganz. dmesg zeigt mir diese Meldung an, wenn
ich das SCSI-Modul lade:


scsi4 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 7.0
<Adaptec 2940A Ultra SCSI adapter>
aic7860: Ultra Single Channel A, SCSI Id=7, 3/253 SCBs

PM: Adding info for No Bus:host4
PM: Adding info for No Bus:target4:0:0
PM: Removing info for No Bus:target4:0:0
PM: Adding info for No Bus:target4:0:1
PM: Removing info for No Bus:target4:0:1
PM: Adding info for No Bus:target4:0:2
PM: Removing info for No Bus:target4:0:2
PM: Adding info for No Bus:target4:0:3
PM: Removing info for No Bus:target4:0:3
PM: Adding info for No Bus:target4:0:4
scsi 4:0:4:0: Sequential-Access ARCHIVE Python 28388-XXX 5.AC PQ: 0 ANSI: 2
target4:0:4: Beginning Domain Validation
target4:0:4: FAST-10 SCSI 7.8 MB/s ST (128 ns, offset 15)
target4:0:4: Domain Validation skipping write tests
target4:0:4: Ending Domain Validation
PM: Adding info for scsi:4:0:4:0
st 4:0:4:0: Attached scsi tape st0
st 4:0:4:0: st0: try direct i/o: yes (alignment 512 B)
st 4:0:4:0: Attached scsi generic sg0 type 1
PM: Adding info for No Bus:target4:0:5
PM: Removing info for No Bus:target4:0:5
PM: Adding info for No Bus:target4:0:6
scsi 4:0:6:0: Direct-Access CDC 94191- 5374 PQ: 0 ANSI: 1
CCS
target4:0:6: Beginning Domain Validation
target4:0:6: Ending Domain Validation
PM: Adding info for scsi:4:0:6:0
sd 4:0:6:0: [sda] READ CAPACITY failed
sd 4:0:6:0: [sda] Result: hostbyte=0x00 driverbyte=0x08
sd 4:0:6:0: [sda] Sense Key : 0x2 [current]
sd 4:0:6:0: [sda] ASC=0x4 ASCQ=0x0
sd 4:0:6:0: [sda] Test WP failed, assume Write Enabled
sd 4:0:6:0: [sda] Asking for cache data failed
sd 4:0:6:0: [sda] Assuming drive cache: write through
sd 4:0:6:0: [sda] Attached SCSI disk
sd 4:0:6:0: Attached scsi generic sg1 type 0


Wisst ihr vielleicht, ob das Ding kaputt ist, oder ist es einfach nur zu
alt, und ich müsste es irgendwie als /dev/sg1 ansprechen? /dev/sda
existiert zwar, Zugriff mit fdisk oder so bringt aber einen I/O
Fehler. "READ CAPACITY failed" klingt auch nicht gerade gut.

Bevor ich es wegwerfe oder lieber aufschraube und an die Wand hànge, wollte
ich lieber mal nachfragen, ob sich da wer auskennt. An sich sieht es ja
kaputt aus. Aber vielleicht ist das Modell ja irgendwie speziell, ich
verstehe nicht warum man es sonst noch kaufen kann. Oder sind das alles
alte Geràte, die nur für diese Platte zertifiziert sind?

Wonko
 

Lesen sie die antworten

#1 helmut
16/05/2008 - 14:39 | Warnen spam
Hallo, Alex,

Du meintest am 16.05.08:

Beim Aufràumen meiner Festplatten habe ich eine alte Seagate ST4766N
(5.25" 760 MB SCSI) entdeckt. Da die Dinger scheinbar immer noch für
> 100 EUR (bis zu $315 habe ich gesehen) verkauft werden, wollte ich
mal testen, ob sie noch geht. Leider nicht so ganz. dmesg zeigt mir
diese Meldung an, wenn ich das SCSI-Modul lade:



Bevor Du die Linux-Werkzeuge nimmst, solltest Du die Werkzeuge nehmen,
die der SCSI-Hostadapter (hoffentlich) anbietet, beim Booten des
Systems. Wenn der Adapter die Platte nicht erkennt, dann lohnen weitere
Experimente nicht. Und wenn er sie erkennt, aber nicht neu einrichten
("formatieren") kann: desgleichen.

Viele Gruesse
Helmut

"Ubuntu" - an African word, meaning "Slackware is too hard for me".

Ähnliche fragen