Alte Software findet unter W8 kein Netzlaufwerk

12/11/2013 - 16:32 von Tilmann Reh | Report spam
Hallo zusammen,

ich habe auf einem neuen Laptop (gekauft mit Windows 8) eine àltere
technische Software installiert, die zuvor klaglos unter XP und 7(64) lief.

Unter Windows 8(64) treten drei merkwürdige Effekte auf:

1. Das Programm muß im Kompatibilitàtsmodus für XP betrieben werden,
ansonsten findet es seine Einstellungen nicht mehr wieder. Interessant,
denn unter 7 geht es auch ohne.

2. Das Programm verlangt beim Start nach Administrator-Rechten, obwohl
es eigentlich nichts entsprechendes tun sollte (und wegen
Einschrànkungen bezüglich der Pfadnamen auch nicht unter C:\Program
Files (x86)\... liegt, sondern in einem Pfad mit "normalen"
Zugriffsrechten). Auch dieser Effekt tritt unter 7 nicht auf. Ich werde
mal versuchen, ob ich mit ProcMon eingrenzen kann, was genau das
Programm versucht - aber wenn ich nichts herausfinde, ist das nicht
tragisch; es wird nur noch relativ selten benutzt und damit kann ich
dann leben. (Erwartungsgemàß startet es bei abgeschalteter
Benutzerkontensteuerung ohne Rückfrage, es hat also etwas mit den
Zugriffsrechten zu tun - da hat sich von 7 nach 8 offenbar etwas
verschàrft.)

3. Der nervigste Fehler ist aber, daß unter Windows 8 das Programm nicht
mehr auf Netzlaufwerke zugreifen kann. Im System ist alles OK, der
Explorer und alle anderen Programme (auch noch erheblich àltere als
dieses) zeigen in den Dialogen brav die Netzlaufwerke an und greifen
auch darauf zu. Dieses eine Programm aber kann die Netzlaufwerke weder
sehen noch darauf zugreifen (getestet durch Aufruf mit Parameter),
obwohl es scheinbar genau wie alle anderen Programme die normalen
systemeigenen Dialoge verwendet. Auch dies tritt unter 7 nicht auf.
Ob hier ein Zusammenhang zu Punkt 2 besteht, kann ich nicht sagen -
allerdings würde es mich wundern, denn gerade mit Administratorrechten
sollten je weniger Einschrànkungen bestehen...

Hat hier jemand eine Idee v.a. zu den "fehlenden" Netzlaufwerken?

Danke,
Tilmann
 

Lesen sie die antworten

#1 Winfried Sonntag
12/11/2013 - 21:45 | Warnen spam
Am 12.11.2013 schrieb Tilmann Reh:

ich habe auf einem neuen Laptop (gekauft mit Windows 8) eine àltere
technische Software installiert, die zuvor klaglos unter XP und 7(64) lief.

Unter Windows 8(64) treten drei merkwürdige Effekte auf:

1. Das Programm muß im Kompatibilitàtsmodus für XP betrieben werden,
ansonsten findet es seine Einstellungen nicht mehr wieder. Interessant,
denn unter 7 geht es auch ohne.



W7 =! W8.

2. Das Programm verlangt beim Start nach Administrator-Rechten, obwohl
es eigentlich nichts entsprechendes tun sollte (und wegen
Einschrànkungen bezüglich der Pfadnamen auch nicht unter C:\Program
Files (x86)\... liegt, sondern in einem Pfad mit "normalen"
Zugriffsrechten). Auch dieser Effekt tritt unter 7 nicht auf. Ich werde



Wie *genau* lautet der Pfad?

3. Der nervigste Fehler ist aber, daß unter Windows 8 das Programm nicht
mehr auf Netzlaufwerke zugreifen kann. Im System ist alles OK, der



Überleg mal, welche Netzlaufwerke hat der *Administrator* verbunden?
Wenn Du als NW-Laufwerke haben willst, dann verbinde sich auch als
Admin zusàtzlich. CMD.EXE als Admin starten und jetzt mit net use x:
\\Server\Freigabe mappen.

Hat hier jemand eine Idee v.a. zu den "fehlenden" Netzlaufwerken?



Der Administrator ist ein anderes Benutzerkonto.

Servus
Winfried
WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
GPO's: http://www.gruppenrichtlinien.de
Reg2xml: http://www.reg2xml.com - Registry Export File Converter

Ähnliche fragen