AMD Sata-Treiber zickt rum + Loesung

17/01/2014 - 19:09 von Michael Landenberger | Report spam
Hallo,

seit einiger Zeit nervte mich ein Rechner mit Gigabyte MA785GT-UD3H unter
Windows 7 damit, dass er mehrmals am Tag quasi unbenutzbar wurde, weil die
Schreib-/Leseraten der Festplatte drastisch einbrachen (teilweise auf weniger
als ein Tausendstel der Normalwerte). Nach einem Neustart war zunàchst wieder
alles ok, allerdings war es nur eine Frage der Zeit, bis derselbe Fehler
wieder auftrat.

Zunàchst dachte ich an einen Hardware-Defekt. Ich habe also ziemlich viel Zeit
damit verbracht, die Hardware auf Fehler abzuklopfen, allerdings ohne Erfolg.
Die Festplatten-SMART-Werte sowie die Schreib-/Leseraten waren ok (letztere
natürlich nur, solange sich der beschriebene Fehler nicht zeigte) und auch ein
HD-Oberflàchentest sowie ein Speichertest ergaben keine Auffàlligkeiten. Der
Fehler trat auch Zurücksetzen der BIOS-Einstellungen samt anschließender
Neukonfiguration noch auf. Im Ereignis-Log von Windows fanden sich jede Menge
Eintràge, die auf Timeouts bei Vorgàngen hinwiesen, die Schreiben bzw. Lesen
von der Platte erforderten, aber bisher lieferte keiner davon einen Hinweis
auf die Ursache.

Heute fiel mir jedoch erstmals folgender Eintrag auf:

Ereignis: "Ein Zurücksetzen auf Geràt "\Device\RaidPort0" wurde ausgegeben."
Protokollname: System
Quelle: amd_sata
Ereignis-ID: 129
Ebene: Warnung

Diese Informationen nutzte ich für eine Google-Suche. Dabei stieß ich auf
<http://social.technet.microsoft.com...eneral>
auf den Hinweis, den (AMD-)Treiber für das Geràt "AMD SATA Controller" durch
den Standard AHCI 1.0-Treiber von Microsoft zu ersetzen.

Und siehe da: der Fehler ist weg. Der Rechner làuft jetzt wieder stabil und
die Schreib-/Leseraten sind normal. Ich werde jetzt nachsehen, ob es einen
neuen Chipsatztreiber für mein Mainboard gibt, wobei ich es mir aber gut
überlegen werde, ob ich den einspiele. Wer weiß, ob ein neuer Treiber nicht
denselben Fehler enthàlt wie der bisher genutzte AMD-Treiber (1.2.1.349 vom
27.6.20139)

Ich hoffe, dieser Hinweis hilft anderen mit einem àhnlichen Problem.

Gruß

Michael
 

Lesen sie die antworten

#1 Bertram Schrahder
17/01/2014 - 20:26 | Warnen spam
On 17.01.2014 19:09, Michael Landenberger wrote:
Hallo,

seit einiger Zeit nervte mich ein Rechner mit Gigabyte MA785GT-UD3H unter
Windows 7 damit, dass er mehrmals am Tag quasi unbenutzbar wurde, weil die



Nur kurz: nach einem z.B. Windows7 Totalschaden bei dem sich das
Windows7 nicht mehr reparieren liess, unendliche probleme mit
Registry/Services Eintraegen auch nicht mittels teurer Microsoft Tech
Support (paid, aber auch schon enterprise support services) beheben
liess, lasse ich insbesondere von den Storage Treibern die Finger welche
das Boot-Device betreffen. Also NIX mit AMD-ata/sata/xata Treibern,
FINGER WEG. Ich fahre nur noch die Microsoft boxed AHCI u.ae. Treiber,
alles andere ist Augenwischerei und Kosmetik, das hat bei mir in
real-life noch nie was gebracht, und es hat mich mehrere Systeme
gekostet. Und nein das hatte nichts mit fehlende Datensicherung oder
aehnliches zu tun, das System war einfach mal so durch thirdparty oder
auch nur durch Microsoft-eigene Updates und Layer so zerstoert, dass es
sich nicht mehr reaktivieren liess und es *hat* Geld gekostet das an
MSFT floss, ohne Ergebnisse.

Die Daten waren vorhanden, es gab auch an sich keinen Datenverlust, wenn
man die ganze Personalisierung, Konfig etc nicht mit einberechnet und
nicht den ganzen Admin-Overhead und Buerokratie.

Nie wieder Sata/Storage Treiber die nicht vanilla Microsoft boxed sind,
bzw nie wieder boot devices die nicht ohne Sondertreiber und
Freak-Treiber auskommen.

B.

Ähnliche fragen