Anfänger-Frage (lande Pause vor dem Laden index.aspx)

08/01/2010 - 09:19 von Juri Pastuchow | Report spam
Hallo
Ich habe mit C# kleine Homepage gemacht(noch nicht fertig).Karate-Verein
I benutze dabei "Microsoft Visual Web Developer 2008 Express Edition"
Alles funktioniert.
Die Seiten werden schnell geladen.
Aber

die Zeit vor dem Laden liegt bei 2-3 Sekunden.
In diesen Moment passiert gar nix.
Man merkt es besonders bei dem ersten Aufruf.
Der Hoster meint,dass alles ok ist.

www.eurotur.de

Ich habe ein Problem , habe nix bei Google gefunden
web.config -- ?ndern ?


F?r jede Hilfe dankbar

MfG J.Pastuchow







Submitted via EggHeadCafe - Software Developer Portal of Choice
.NET Number and Currency Formatting
http://www.eggheadcafe.com/tutorial...rency.aspx
 

Lesen sie die antworten

#1 Stefan Falz [MVP]
08/01/2010 - 09:30 | Warnen spam
Hallo Juri,

"Juri Pastuchow" schrieb:

die Zeit vor dem Laden liegt bei 2-3 Sekunden.
In diesen Moment passiert gar nix.
Man merkt es besonders bei dem ersten Aufruf.



beim ersten Aufruf wird die Anwendung auf dem Server kompiliert.
Daher dauert der erste Aufruf immer etwas lànger. Dasselbe
passiert auch, wenn der Application Pool beendet wurde und dann
der nàchste Request kommt.

Ich habe ein Problem , habe nix bei Google gefunden



Du hast kein Problem, nur eine Anwendung, die nicht oft besucht
wird :) Da zeigt sich das natürlich hàufiger. Wenn die Anwendung
dann mal fertig ist und massig Besucher da sind, tritt das in
der Form so nicht mehr auf.

Beim Veröffentlichen solltest Du darauf achten, dass die Anwendung
als Release kompiliert wird und in der web.config ... debug="false"
steht.

http://www.aspnetzone.de/blogs/stef...ation.aspx

Tschau, Stefan
Microsoft MVP - Visual Developer ASP/ASP.NET
http://www.asp-solutions.de/ - Consulting, Development
http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

Ähnliche fragen