Anwendung verabschiedet sich plötzlich und kommentarlos

12/12/2011 - 10:42 von Herbert Fidesser | Report spam
Hallo,

so langsam bin ich am Verzweifeln:
Ich entwickle unter Access 2010 und Windows 7 eine umfangreiche Lösung
mit einer MySQL-DB als Backend und Frontend Access 2010. Enthalten
sind ca. 50 Tabellen mit bis zu 80 Feldern, 10 PassThrough-Abfragen,
ca. 50 Formulare und UFOs und 20 Berichte.

Das Problem:
Nach 5 bis 30 Minuten Entwicklungsarbeit und Beenden làsst sich meine
Frontend zwar wieder starten, aber sobald ich eine Tabelle oder ein
Formular öffne (Entwurfs- oder Formularansicht) oder in die VBA-
Umgebung gehe, schließt sich Acccess kommentarlos und ich kann nur
wieder bei der letzten Sicherung aufsetzen.
Das zwingt mich, alle 5 Minuten die Arbeit zu beenden, eine Kopie zu
ziehen und - mit Glück - die Frontend wieder zu starten (oder eben bei
der letzten funktionierenden Kopie wieder zu beginnen).

Reparieren/Komprimieren hift auch nicht, da sich Access auch hier
kommentarlos verabschiedet.
Ich habe auch schon alle Objekte in eine neue Access-Datei kopiert
bzw. neu eingebunden. Hat auch nichts geàndert.
Beim Debuggen wird kein Fehler im Code gemeldet.

VBA-Verweise sind:
Visual Basic for Applications,
Microsoft Access 14.0 Object Library,
OLE Automation,
Microsoft Office 14.0 Access database engine Object Library,
Microsoft Visual Basic for Applications Extensibility 5.3,
Microsoft Office 14.0 Object Library

Kennt jemand dieses Phànomen? Weiß jemand vielleicht sogar eine
Lösung?
Ich wàre für jeden Hinweis dankbar.

Beste Grüße
Herbert
 

Lesen sie die antworten

#1 Karl Donaubauer
12/12/2011 - 11:56 | Warnen spam
Herbert Fidesser wrote:

so langsam bin ich am Verzweifeln:
Ich entwickle unter Access 2010 und Windows 7 eine umfangreiche Lösung
mit einer MySQL-DB als Backend und Frontend Access 2010.
...
Nach 5 bis 30 Minuten Entwicklungsarbeit und Beenden làsst sich meine
Frontend zwar wieder starten, aber sobald ich eine Tabelle oder ein
Formular öffne (Entwurfs- oder Formularansicht) oder in die VBA-
Umgebung gehe, schließt sich Acccess kommentarlos und ich kann nur
wieder bei der letzten Sicherung aufsetzen.
...



Hast du das SP1 für O10 installiert?
Das verursacht gerne allerhand Abstürze und sonstige Probleme.

Wenn ja, dann versuche entweder eine Deinstallation des SP1
oder installiere die Hotfixes:
http://support.microsoft.com/kb/2618119

v.a. diesen, der eh im kumulativen Update dabei ist:
http://support.microsoft.com/kb/2596585

Eine Reparatur von O/A10 könntest du auch noch versuchen.

Servus
Karl
*********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen