Anwendungen zeigen falsche Zeichen

08/04/2009 - 21:57 von Markus Wichmann | Report spam
Hi all,

ich habe da ein Problem mit meinem xterm. Genauer gesagt benutze ich das
uxterm, aber im xterm tritt der gleiche Fehler auf: Obwohl laut xmodmap
alles in Ordnung ist, werden falsche Zeichen eingegeben, wenn ich
Kombinationen mit AltGr benutzen möchte. Beispielsweise liefert die
öffnende geschweifte Klammer ein û. Dies ist auch im raw mode so.

Ich weiß leider nicht, wo ich suchen soll: Laut xev kommt das richtige
Keysym an, aber jede Anwendung verweigert entweder die Annahme der
Zeichen oder zeigt Seltsames ein.

$ xmodmap -pke ¦ grep 'keycode 16'
keycode 16 = 7 slash braceleft seveneighths braceleft seveneighths

(stellt euch statt des broken bar eine pipe vor)

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL
$ appres
*XTerm*background: black
*Xterm*allowTcapOps: true
*Xterm*allowFontOps: true
*Xterm*foreground: white
*Xterm*allowSendEvents: true
*Xterm*allowC1Printable: true

$ grep -i xkb /etc/X11/xorg.conf
Option "XkbRules" "xorg"
Option "XkbModel" "thinkpad60"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "compose:lwin"

Wo kann ich noch suchen?

Tschö,
Markus

GUI - ein Hintergrundbild und zwölf XTerms

vim -c "exec \"norm iwHFG#NABGURE#IVZ#UNPXRE\"|%s/#/ /g|norm g??g~~"
 

Lesen sie die antworten

#1 Sieghard Schicktanz
09/04/2009 - 01:47 | Warnen spam
Hallo Markus,

Du schriebst am Wed, 8 Apr 2009 21:57:37 +0200:

ich habe da ein Problem mit meinem xterm. Genauer gesagt benutze ich das
uxterm, aber im xterm tritt der gleiche Fehler auf: Obwohl laut xmodmap



Ich bevorzuge das (u)rxvt, da funktioniert der mc vollstàndig.

alles in Ordnung ist, werden falsche Zeichen eingegeben, wenn ich


...
$ grep -i xkb /etc/X11/xorg.conf
Option "XkbRules" "xorg"
Option "XkbModel" "thinkpad60"



Ist das auch ein "Thinkpad 60"?

Wo kann ich noch suchen?



Z.B. unter 'Section "ServerFlags"' nach

Option "AllowEmptyInput" "off"
Option "AutoAddDevices" "off"

- wenn das fehlt, wird Deine Einstellung wahrscheinlich ignoriert, sofern
der "hal" was anderes liefert - wohl auch, wenn der _gar_ _nichts_ liefert
(z.B. weil er gar nicht làuft;).
Da ist das aktuelle Xorg unbarmherzig und unerbittlich... :->

(Weitergabe von Adressdaten, Telefonnummern u.à. ohne Zustimmung
nicht gestattet, ebenso Zusendung von Werbung oder àhnlichem)
Mit freundlichen Grüßen, S. Schicktanz

Ähnliche fragen