apache2_2.4.10-11 zickt rum

31/05/2015 - 23:20 von Joachim Hartmann | Report spam
Hallo,
nach einem unfreiwilligen Umstieg auf stretch und damit auch
- von apache2_2.2.22-13
- auf apache2_2.4.10-11
haben sich mehrere Probleme ergeben, von denen ich auch schon einig
beheben konnte.
Der Web-Server startet grundsàtzlich aber nur mit eingeschrànkten
Funktionen, Aptitude meldet dazu:

###################################################################################################################
22:58:26#~# aptitude safe-upgrade
Die folgenden teilweise installierten Pakete werden konfiguriert:
apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 php5
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusàtzlich installiert, 0 werden entfernt und 0
nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden
0 B zusàtzlich belegt sein.
apache2 (2.4.10-11) wird eingerichtet ...
disable obsolete module proxy
ERROR: The following modules depend on proxy and need to be disabled
first: proxy_http
dpkg: Fehler beim Bearbeiten des Paketes apache2 (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert
1 zurück
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von apache2.2-common:
apache2.2-common hàngt ab von apache2 (>= 2.3~); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes apache2.2-common (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libapache2-mod-php5:
libapache2-mod-php5 hàngt ab von apache2 (>= 2.4); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libapache2-mod-php5 (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von php5:
php5 hàngt ab von libapache2-mod-php5 (>= 5.6.9+dfsg-1~) |
libapache2-mod-php5filter (>= 5.6.9+dfsg-1~) | php5-cgi (>=
5.6.9+dfsg-1~) | php5-fpm (>= 5.6.9+dfsg-1~); aber:
Paket libapache2-mod-php5 ist noch nicht konfiguriert.
Paket libapache2-mod-php5filter ist nicht installiert.
Paket php5-cgi ist nicht installiert.
Paket php5-fpm ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes php5 (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
apache2-mpm-prefork:
apache2-mpm-prefork hàngt ab von apache2 (= 2.4.10-11); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes apache2-mpm-prefork (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
apache2
apache2.2-common
libapache2-mod-php5
php5
apache2-mpm-prefork
E: Sub-process /usr/bin/dpkg returned an error code (1)
Failed to perform requested operation on package. Trying to recover:
apache2 (2.4.10-11) wird eingerichtet ...
disable obsolete module proxy
ERROR: The following modules depend on proxy and need to be disabled
first: proxy_http
dpkg: Fehler beim Bearbeiten des Paketes apache2 (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert
1 zurück
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von apache2.2-common:
apache2.2-common hàngt ab von apache2 (>= 2.3~); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes apache2.2-common (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
apache2-mpm-prefork:
apache2-mpm-prefork hàngt ab von apache2 (= 2.4.10-11); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes apache2-mpm-prefork (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
libapache2-mod-php5:
libapache2-mod-php5 hàngt ab von apache2 (>= 2.4); aber:
Paket apache2 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libapache2-mod-php5 (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von php5:
php5 hàngt ab von libapache2-mod-php5 (>= 5.6.9+dfsg-1~) |
libapache2-mod-php5filter (>= 5.6.9+dfsg-1~) | php5-cgi (>=
5.6.9+dfsg-1~) | php5-fpm (>= 5.6.9+dfsg-1~); aber:
Paket libapache2-mod-php5 ist noch nicht konfiguriert.
Paket libapache2-mod-php5filter ist nicht installiert.
Paket php5-cgi ist nicht installiert.
Paket php5-fpm ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes php5 (--configure):
Abhàngigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
apache2
apache2.2-common
apache2-mpm-prefork
libapache2-mod-php5
php5

22:59:14#~#
###################################################################################################################

wer weiß Rat?

Gruß aus der Stadt der CeBIT
Jochen


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/556B794F.4000806@gmx-topmail.de
 

Lesen sie die antworten

#1 Jochen Spieker
31/05/2015 - 23:40 | Warnen spam

Joachim Hartmann:

###################################################################################################################
22:58:26#~# aptitude safe-upgrade
Die folgenden teilweise installierten Pakete werden konfiguriert:
apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 php5



Die Pakete apache2-mpm-* sind nur noch Dummies, die kannst Du weglassen.
Bei Apache 2.4 sind die MPMs nur noch Module, die Du wie alle anderen
Module auch (de-)aktivieren kannst (a2enmod/a2dismod).

Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusàtzlich installiert, 0 werden entfernt und 0
nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 0 B
zusàtzlich belegt sein.
apache2 (2.4.10-11) wird eingerichtet ...
disable obsolete module proxy
ERROR: The following modules depend on proxy and need to be disabled first:
proxy_http



a2dismod proxy_http

Ich verstehe aber nicht, warum das passiert. Sowohl proxy als auch
http_proxy sind in Apache 2.4 enthalten. Hast Du gerade einen
Mischzustand 2.2/2.4 installiert? Wie auch immer, deaktiviere mal das
angemeckerte Modul und probiere nochmal. Der Rest dürften Folgefehler
sein.

J.
I lust after strangers but only date people from the office.
[Agree] [Disagree]
<http://www.slowlydownward.com/NODAT...2.html>





Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen