aptitude dist-upgrade auf Debian lenny bricht ab

22/02/2009 - 00:29 von Anton Blau | Report spam
Hallo Newsgroup,

das Upgrade auf lenny bricht leider hier ab:

Wollen Sie fortsetzen? [Y/n/?]
Schreibe erweiterte Statusinformationen... Fertig
Lese Changelogs...
Extracting templates from packages: 100%
Preconfiguring packages ...
Richte python ein (2.5.2-3) ...
running python rtupdate hooks for python2.5...
Compiling /usr/lib/python2.5/site-packages/spambayes/FileCorpus.py ...
File "/usr/lib/python2.5/site-packages/spambayes/FileCorpus.py", line 85
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /usr/lib/python2.5/site-packages/spambayes/message.py ...
File "/usr/lib/python2.5/site-packages/spambayes/message.py", line 78
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /usr/lib/python2.5/site-packages/spambayes/Corpus.py ...
File "/usr/lib/python2.5/site-packages/spambayes/Corpus.py", line 82
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

pycentral: pycentral updatedefault: error byte-compiling files (48)
pycentral updatedefault: error byte-compiling files (48)
error running python rtupdate hook pycentral
dpkg: Fehler beim Bearbeiten von python (--configure):
Unterprozess post-installation script gab den Fehlerwert 4 zurück
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von openssl-blacklist:
openssl-blacklist hàngt ab von python; aber:
Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von openssl-blacklist (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von ssl-cert:
ssl-cert hàngt ab von openssl-blacklist; aber:
Paket openssl-blacklist ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von ssl-cert (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von cups:
cups hàngt ab von ssl-cert (>= 1.0.11); aber:
Paket ssl-cert ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von cups (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
python
openssl-blacklist
ssl-cert
cups
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
Richte python ein (2.5.2-3) ...
running python rtupdate hooks for python2.5...
Compiling /usr/lib/python2.5/site-packages/spambayes/FileCorpus.py ...
File "/usr/lib/python2.5/site-packages/spambayes/FileCorpus.py", line 85
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /usr/lib/python2.5/site-packages/spambayes/message.py ...
File "/usr/lib/python2.5/site-packages/spambayes/message.py", line 78
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /usr/lib/python2.5/site-packages/spambayes/Corpus.py ...
File "/usr/lib/python2.5/site-packages/spambayes/Corpus.py", line 82
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

pycentral: pycentral updatedefault: error byte-compiling files (48)
pycentral updatedefault: error byte-compiling files (48)
error running python rtupdate hook pycentral
dpkg: Fehler beim Bearbeiten von python (--configure):
Unterprozess post-installation script gab den Fehlerwert 4 zurück
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von python-newt:
python-newt hàngt ab von python (<< 2.6); aber:
Paket python ist noch nicht konfiguriert.
python-newt hàngt ab von python (>= 2.4); aber:
Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-newt (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von python-support:
python-support hàngt ab von python (>= 2.4); aber:
Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-support (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von capisuite:
capisuite hàngt ab von python (<< 2.6); aber:
Paket python ist noch nicht konfiguriert.
capisuite hàngt ab von python (>= 2.5); aber:
Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von capisuite (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von openssl-blacklist:
openssl-blacklist hàngt ab von python; aber:
Paket python ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von openssl-blacklist (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von ssl-cert:
ssl-cert hàngt ab von openssl-blacklist; aber:
Paket openssl-blacklist ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von ssl-cert (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von python-selinux:
python-selinux hàngt ab von python (>= 2.4); aber:
Paket python ist noch nicht konfiguriert.
python-selinux hàngt ab von python (<< 2.6); aber:
Paket python ist noch nicht konfiguriert.
python-selinux hàngt ab von python-support (>= 0.7.1); aber:
Paket python-support ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von python-selinux (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von cups:
cups hàngt ab von ssl-cert (>= 1.0.11); aber:
Paket ssl-cert ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von cups (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
cups-driver-gutenprint:
cups-driver-gutenprint hàngt ab von cups (>= 1.3.7-6); aber:
Paket cups ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von cups-driver-gutenprint (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von
cupsys-driver-gutenprint:
cupsys-driver-gutenprint hàngt ab von cups-driver-gutenprint (>=
5.0.2-4); aber:
Paket cups-driver-gutenprint ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von cupsys-driver-gutenprint (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhàngigkeitsprobleme verhindern Konfiguration von cupsys:
cupsys hàngt ab von cups; aber:
Paket cups ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von cupsys (--configure):
Abhàngigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
python
python-newt
python-support
capisuite
openssl-blacklist
ssl-cert
python-selinux
cups
cups-driver-gutenprint
cupsys-driver-gutenprint
cupsys
Paketlisten werden gelesen... Fertig
Abhàngigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Lese erweiterte Statusinformationen
Initialisiere Paketstatus... Fertig
Schreibe erweiterte Statusinformationen... Fertig
Lese Task-Beschreibungen... Fertig


Wie komme ich denn hier weiter?

Danke!




Haeufig gestellte Fragen und Antworten (FAQ):
http://www.de.debian.org/debian-user-german-FAQ/

Zum AUSTRAGEN schicken Sie eine Mail an
debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an
listmaster@lists.debian.org (engl)
 

Lesen sie die antworten

#1 Christoph Mehdorn Weber
15/04/2009 - 17:57 | Warnen spam
Hallo!

* Anton Blau :

Richte python ein (2.5.2-3) ...
running python rtupdate hooks for python2.5...
Compiling /usr/lib/python2.5/site-packages/spambayes/FileCorpus.py ...
File "/usr/lib/python2.5/site-packages/spambayes/FileCorpus.py", line 85
from __future__ import generators
SyntaxError: from __future__ imports must occur at the beginning of the file

Wie komme ich denn hier weiter?



Falls sich das Problem nicht inzwischen durch Updates seitens
Debian selbst gelöst hat, fallen mir drei Wege ein:

1. Python-Paket durch Bearbeiten von /var/lib/dpkg/info/python.*
so veràndern, daß es sich ohne den Compileversuch installieren
làßt. Dann sollten die restlichen Pakete ins System kommen, und
wenn das System vollstàndig aktuell ist, macht man die Änderung
rückgàngig und Python kompiliert hoffentlich durch.

Veràndern könnte heißen: vor dem Aufruf von rtupdate ein
"exit 0" hineinschreiben.

2. In der grafischen Variante von aptitude nachgucken, welche
anderen Python-Pakete da noch nicht aktuell sind und diese
gleichzeitig mit aktualisieren lassen oder alternativ
entfernen. Eventuell beseitigt das den Konflikt.

3. Mit dpkg --get-selections eine aktuelle Paketliste sichern.
Danach mit 'dpkg -P --force-depends <paket>' alle Problempakete
entfernen.

Bei Bedarf vorher die Konfigdateien sichern. Danach die Pakete
wieder per aptitude einspielen und gucken, ob sich das Problem
gelöst hat:

Fehler traten auf beim Bearbeiten von:
python
python-newt
python-support
capisuite
openssl-blacklist
ssl-cert
python-selinux
cups
cups-driver-gutenprint
cupsys-driver-gutenprint
cupsys



Wenn nicht, wiederholen wir den Vorgang ohne --force-depends
und entfernen somit auch die abhàngigen Pakete. Nach dieser
Roßkur sollte das im Normalfall aber wieder passen.


Ganz alternativ könntest du es mit einer Neuinstallation
versuchen, da du eh schon ein --get-selections gemacht hast.
Auf einer Minimalinstallation starte "dpkg --clear-selections
nachgebildet bekommen. Du mußt dann allerdings noch die
Konfigurationen und Nutzerdaten umziehen.

Aber eventuell geht das schneller, je nachdem, wie weite
Kreise die Abhàngigkeiten mit der dritten Methode ziehen.

Christoph

Was ist "richtige EDV"? Ein IBM Mainframe mit 35 Suse-Partitionen?
(Roger Schwentker)

Ähnliche fragen