Asus-Motherboard MSA 78L USB3 und eth0

24/11/2011 - 14:16 von Peter Blancke | Report spam
Guten Tag,

es gibt Probleme mit der Ethernet-Schnittstelle auf o. a.
Motherboard.

dmesg meldet (MAC von mir unkenntlich gemacht):

[ 2.626595] r8169 0000:02:00.0: eth0: RTL8168b/8111b at 0xf7dd4000,
14:da:e9:XX:XX:XX, XID 0c900800 IRQ 43
[ 42.224727] r8169 0000:02:00.0: eth0: link down
[ 42.224735] r8169 0000:02:00.0: eth0: link down

lspci wirft folgende Zeilen:

00:00.0 Host bridge: Advanced Micro Devices [AMD]
RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD]
RS780 PCI to PCI bridge (ext gfx port 0)
00:04.0 PCI bridge: Advanced Micro Devices [AMD]
RS780 PCI to PCI bridge (PCIE port 0)
00:07.0 PCI bridge: Advanced Micro Devices [AMD]
RS780 PCI to PCI bridge (PCIE port 3)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Als Module fuer die Ethernetschnittstelle werden folglich "mii" und
"r8169" geladen.

Bei Uebertragungen auf der Ethernetschnittstelle bemerke ich, dasz
die Uebertragung immer langsamer wird und am Ende voellig stehen
bleibt.

ifconfig sieht dann so aus:

eth0 Link encap:Ethernet HWaddr 14:da:e9:XX:XX:XX
inet addr:192.168.XX.XXX Bcast:192.168.XX.XXX Mask:255.255.255.0
inet6 addr: fe80::XXXX:XXXX:XXXX:XXXX/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:239616 errors:0 dropped:239616 overruns:0 frame:239616
TX packets:139628 errors:0 dropped:3 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:358933131 (342.3 MiB) TX bytes:9927149 (9.4 MiB)
Interrupt:43 Base address:0x4000

Normalerweise wuerde ich jetzt einen Hardwaredefekt diagnostizieren.
Aber: Ein aufgespieltes Windows arbeitet mit den mitgelieferten
Realtek-Netzwerktreibern einwandfrei ueber die Netzwerkkarte und ich
habe die Fehler auf ALLEN Asus-Boards dieser Baureihe, die ich in
vergangenen Wochen verbaut habe (etwa 6 Stueck).

Zur Anwendung kam Debian/Squeeze mit Kernel 2.6.32 bzw. eine
Rettungs-CD mit Kernel 2.6.38. Beide Kernel haben die gleichen
Probleme.

Wo mag das Problem sein?

Grusz,

Peter Blancke

Hoc est enim verbum meum!
 

Lesen sie die antworten

#1 Sieghard Schicktanz
24/11/2011 - 20:22 | Warnen spam
Hallo Peter,

Du schriebst am Thu, 24 Nov 2011 13:16:33 +0000 (UTC):

es gibt Probleme mit der Ethernet-Schnittstelle auf o. a.
Motherboard.


...
Als Module fuer die Ethernetschnittstelle werden folglich "mii" und
"r8169" geladen.


^^^^^
Damit hatte ich auch schon mal Probleme, und zwar mit dem Kernel 2.6.38...

Bei Uebertragungen auf der Ethernetschnittstelle bemerke ich, dasz
die Uebertragung immer langsamer wird und am Ende voellig stehen



Bei meiner Kiste mit dem Chip ging allerdings gleich garnichts mehr...

ifconfig sieht dann so aus:



Konfigurationsmàßig sah auch alles richtig aus - es funktionierte nur nicht.

Normalerweise wuerde ich jetzt einen Hardwaredefekt diagnostizieren.
Aber: Ein aufgespieltes Windows arbeitet mit den mitgelieferten
Realtek-Netzwerktreibern einwandfrei ueber die Netzwerkkarte und ich
habe die Fehler auf ALLEN Asus-Boards dieser Baureihe, die ich in
vergangenen Wochen verbaut habe (etwa 6 Stueck).



Bei meiner Maschine ging es vorher mit dem 2.6.36 (AFAIR) noch
einwandfrei...

Zur Anwendung kam Debian/Squeeze mit Kernel 2.6.32 bzw. eine
Rettungs-CD mit Kernel 2.6.38. Beide Kernel haben die gleichen
Probleme.



... mit dem 2.6.38 dann _nicht_ mehr.

Wo mag das Problem sein?



Im Kernel, vermutlich. Kurz nach dem das Problem hier aufgetaucht war, kam
bei meiner Distribution (Arch-Linux) der Kernel 2.6.39 heraus; nachdem ich
den installiert hatte (vorher hatte ich noch mit einem Firmen-Treiber
versucht, der auch nicht ging), funktionierte das Netzwerk wieder völlig
problemlos.

(Weitergabe von Adressdaten, Telefonnummern u.à. ohne Zustimmung
nicht gestattet, ebenso Zusendung von Werbung oder àhnlichem)
Mit freundlichen Grüßen, S. Schicktanz

Ähnliche fragen