AT+CGDCONT= ... ERROR

23/02/2012 - 04:09 von Hans-Joachim Zierke | Report spam
Man kann ja nicht ewig den (Huawei 160) UMTS-Stick vom Nachbarn leihen,
also kam gestern mein eigener.


Er sollte problemlos mit Linux funktionieren, mindestens 7,6 MBit/s
können, einen Antennenanschluß haben, und SMS mit gammu versenden können.
Also habe ich
http://wiki.debian.org/Modem/3G
beguckt und mir einen Huawei E176 bestellt.

Wird problemlos erkannt, umgeschaltet, /dev/ttyUSB 0 und 1 werden
automatisch angelegt, alles, wie es sein soll.

Auf ATI antwortet er mit
#v+
ATI

Manufacturer: huawei
Model: E176
Revision: 11.124.05.01.266
IMEI: 35XXXXXXXXXXXXX
+GCAP: +CGSM,+DS,+ES

OK
#v-


Jetzt das Problem: Der Stick frißt alle normalen AT-Kommandos. Man kann
ihm ein ATQ0V1E1S0=0&C1&D2+FCLASS=0 zuwerfen, nimmt er. Sobald man aber
einen AT-Befehl für die Verbindungsaufnahme übergibt, sagen wir
AT+CGQREQ=1,2,4,3,9,31
oder
AT+CGDCONT=1,"IP","internet.eplus.de"
, dann gibt's nur noch ERROR.


Mein erster Gedanke war: "Der ist gelockt." Das Ding hat einen Aufkleber
von Movistar, das ist ein Provider in Spanien und Südamerika. Könnte also
gut sein. Also noch mal minicom angeworfen und
#v+
AT^CARDLOCK?
^CARDLOCK: 2,10,0
#v-

Tja, gelockt ist er nicht. Und jetzt kratze ich mich am Kopf, und weiß
nicht mehr weiter. Das "works out of the box" im Debian-Wiki hatte ich
mir irgendwie anders vorgestellt.



Hans-Joachim
 

Lesen sie die antworten

#1 Norbert Möndjen
23/02/2012 - 07:53 | Warnen spam
Hans-Joachim Zierke wrote:

Jetzt das Problem: Der Stick frißt alle normalen AT-Kommandos. Man kann
ihm ein ATQ0V1E1S0=0&C1&D2+FCLASS=0 zuwerfen, nimmt er. Sobald man aber
einen AT-Befehl für die Verbindungsaufnahme übergibt, sagen wir
AT+CGQREQ=1,2,4,3,9,31
oder
AT+CGDCONT=1,"IP","internet.eplus.de"
, dann gibt's nur noch ERROR.



Versuch mal die Pin-Code Abfrage auszuschalten. Das hat es bei mir gebracht.

Ciao Nobbe

Ähnliche fragen