AT91SAM7S128 Reset und die Betriebsspannung

10/02/2014 - 19:04 von Michael Schlegel | Report spam
Hallo,

ich stehe kurz vor der totalen Vezweiflung.

Nachdem ich die USB-Probleme in den Griff bekommen habe und eigentlich schon
fast am Ausliefern war musste ich feststellen, dass der Reset-Controller mit
steigender Temperatur zu spinnen beginnt. Dabei geht weder Power-On Reset
noch der nReset Eingang. Kühlt man das Teil oder steckt den JTAG-Debugger an
geht alles wunderbar. Auch wenn er erst mal làuft, stört keine erhöhte
Temperatur.
Interessanterweise sind mir in meiner 1. Serie keinerlei derartigen Probleme
aufgefallen. Unterschied zur zum aktuellen Design ist eigentlich nur, dass
die 3.3V nicht mehr aus einem Festspannungsregler kommen sondern aus einem
LM317 und die SMD-Bauteile (wie Abblock-C) vom Bestücker kommen.
Erhöhe ich die Betriebsspannung z.B. auf 3.7V wird die ganze Sache
zuverlàssiger, aber das Datenblatt sagt eigentlich 3..3.6V.

dankbar für alle Hinweise,
Michael
 

Lesen sie die antworten

#1 Frank Buss
10/02/2014 - 19:19 | Warnen spam
Michael Schlegel wrote:

Nachdem ich die USB-Probleme in den Griff bekommen habe und eigentlich schon
fast am Ausliefern war musste ich feststellen, dass der Reset-Controller mit
steigender Temperatur zu spinnen beginnt. Dabei geht weder Power-On Reset
noch der nReset Eingang. Kühlt man das Teil oder steckt den JTAG-Debugger an
geht alles wunderbar. Auch wenn er erst mal làuft, stört keine erhöhte
Temperatur.
Interessanterweise sind mir in meiner 1. Serie keinerlei derartigen Probleme
aufgefallen. Unterschied zur zum aktuellen Design ist eigentlich nur, dass
die 3.3V nicht mehr aus einem Festspannungsregler kommen sondern aus einem
LM317 und die SMD-Bauteile (wie Abblock-C) vom Bestücker kommen.
Erhöhe ich die Betriebsspannung z.B. auf 3.7V wird die ganze Sache
zuverlàssiger, aber das Datenblatt sagt eigentlich 3..3.6V.



Hast du auch die genaue Reihenfolge der Spannungen beachtet? Ich meine
mich zu erinnern, daß es ziemlich empfindlich ist, wann die Core
Spannung anliegen muß und wann die 3,3V und wie schnell oder langsam die
Spannungen steigen. Außerdem war das mit dem Takt kritisch, also wann
der Slow-Clock anliegen muß usw.

Ich habe bei einem Produkt mitgearbeitet (nur als Programmierer) wo ein
Chip der AT91SAM-Reihe eingesetzt wurde und da ging das aber auch nicht
alles zuverlàssig. Wir haben dann dort schließlich einen externen
Watchdog-Chip mit verbaut, um die Fàlle abzufangen, wenn es mal nicht
anspringt. Ich vermute Atmel-Chips werden in der Firma nicht mehr so
schnell eingesetzt werden :-)

Frank Buss, http://www.frank-buss.de
electronics and more: http://www.youtube.com/user/frankbuss

Ähnliche fragen