atd checkts nicht mit dem Datum

20/05/2016 - 11:00 von Andre Tann | Report spam
Servus Leute,

ich steh hier grad auf dem Schlauch:

atann@a03:~$ echo hallo | at 10:44 28.05.2016
warning: commands will be executed using /bin/sh
job 15 at Sat May 28 10:44:00 2016

Der Job wurde daraufhin heute um 10:44 ausgeführt. Aber warum?!? Ich
kapier das grad echt nicht. Da steht doch als Zeitdefinition Sat May 28,
also hat atd die Zeit doch korrekt mitgekriegt. Hab das jetzt mehrmals
nachvollziehen können: Die Uhrzeit-Definition wirkt, die Datumsangabe nicht.

Auf einer SuSE-Installation làuft das wie erwartet. Haben wir hier einen
Bug? Kann das jemand nachvollziehen?

Ich bitte um Erhellung.

Andre Tann
 

Lesen sie die antworten

#1 Matthias Böttcher
20/05/2016 - 11:20 | Warnen spam
Hallo Andre,

wie sehe die Ausgaben von
date
atq

aus, nachdem du "echo hallo | at 10:44 28.05.2016" (bzw. mit einer
anderen Uhrzeit) abgesetzt hast?

Matthias

Am 20. Mai 2016 um 10:52 schrieb Andre Tann :
Servus Leute,

ich steh hier grad auf dem Schlauch:

:~$ echo hallo | at 10:44 28.05.2016
warning: commands will be executed using /bin/sh
job 15 at Sat May 28 10:44:00 2016

Der Job wurde daraufhin heute um 10:44 ausgeführt. Aber warum?!? Ich kapier
das grad echt nicht. Da steht doch als Zeitdefinition Sat May 28, also hat
atd die Zeit doch korrekt mitgekriegt. Hab das jetzt mehrmals nachvollziehen
können: Die Uhrzeit-Definition wirkt, die Datumsangabe nicht.

Auf einer SuSE-Installation làuft das wie erwartet. Haben wir hier einen
Bug? Kann das jemand nachvollziehen?

Ich bitte um Erhellung.

Andre Tann


Ähnliche fragen