Atheros: "Rx invalid nwid" erhöht sich sehr schnell

21/03/2008 - 16:11 von Gerd Geppert | Report spam
Hallo!

Seit ich in meinem Laptop (Dell Inspiron 6000, Ubuntu 7.10, madwifi_ng)
diese Karte:

,--
| Ethernet controller: Atheros Communications, Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
'--

eingebaut habe, steigt der Wert von "Rx invalid nwid" sehr schnell an.

Hier mal zwei Ausgaben von iwconfig mit dazugehöriger Zeit:

,--
| ~$ date && iwconfig
| Fr 21. Màr 15:11:06 CET 2008
| lo no wireless extensions.
|
| eth0 no wireless extensions.
|
| wifi0 no wireless extensions.
|
| ath0 IEEE 802.11g ESSID:"xxxxxxxxxxx" Nickname:""
| Mode:Managed Frequency:2.412 GHz Access Point: xxxxxxxxxxxxxxxxxx
| Bit Rate:54 Mb/s Tx-Power dBm Sensitivity=1/1
| Retry:off RTS thr:off Fragment thr:off
| Power Management:off
| Link QualityF/70 Signal level=-49 dBm Noise level=-95 dBm
| Rx invalid nwid:207316 Rx invalid crypt:0 Rx invalid frag:0
| Tx excessive retries:0 Invalid misc:0 Missed beacon:0
|
|
| ~$ date && iwconfig
| Fr 21. Màr 15:13:33 CET 2008
| lo no wireless extensions.
|
| eth0 no wireless extensions.
|
| wifi0 no wireless extensions.
|
| ath0 IEEE 802.11g ESSID:"xxxxxxxxxxx" Nickname:""
| Mode:Managed Frequency:2.412 GHz Access Point: xxxxxxxxxxxxxxxxxx
| Bit Rate:18 Mb/s Tx-Power dBm Sensitivity=1/1
| Retry:off RTS thr:off Fragment thr:off
| Power Management:off
| Link QualityE/70 Signal level=-51 dBm Noise level=-96 dBm
| Rx invalid nwid:213803 Rx invalid crypt:0 Rx invalid frag:0
| Tx excessive retries:0 Invalid misc:0 Missed beacon:0
'--

Die Verbindungsgeschwindigkeit fàllt vermutlich deshalb z.T. bis auf
6Mb/s ab.
Auf dem verwendeten Kanal ist ein weiterer AP vorhanden, der mit ca.
-83 bis -81 dBm zu empfangen ist.

Deshalb habe ich schon versucht, mit "iwconfig ath0 sens -78" die
Sensitivity zu àndern. Geht aber nicht:

,--
| Error for wireless request "Set Sensitivity" (8B08) :
| SET failed on device ath0 ; Operation not supported.
'--

Ein Kanalwechsel bringt mir nichts, ich habe schon den günstigsten
Kanal gewàhlt. Kismet zeigt mir hier 20 Staionen an :-(

Hat noch jemand eine Idee, wie ich die Verbindungsgeschwindigkeit zum
Router stabilisieren kann?

TIA

Gerd
 

Lesen sie die antworten

#1 Till Wollenberg
21/06/2008 - 20:20 | Warnen spam
Hallo!

* "Gerd Geppert" schrieb:
Hier mal zwei Ausgaben von iwconfig mit dazugehöriger Zeit:
| Fr 21. Màr 15:11:06 CET 2008
| Rx invalid nwid:207316 Rx invalid crypt:0 Rx invalid frag:0
|
| Fr 21. Màr 15:13:33 CET 2008
| Rx invalid nwid:213803 Rx invalid crypt:0 Rx invalid frag:0



Der "invalid nwid"-Zàhler gibt die Anzahl korrekt empfangener Frames an, die
nicht zur eigenen BSSID passen, also zu einem anderen Netz gehören.

Die Verbindungsgeschwindigkeit fàllt vermutlich deshalb z.T. bis auf
6Mb/s ab.
Auf dem verwendeten Kanal ist ein weiterer AP vorhanden, der mit ca.
-83 bis -81 dBm zu empfangen ist.



Mehrere APs auf ein und demselben Kanal sind erstmal keine Katastrophe. Im
Idealfall empfangen die Teilnehmer der verschiedenen Netze die jeweils anderen
Netze und können daher ihre Aussendungen entsprechend koordinieren. Im Ergebnis
teilen sich dann alle die zur Verfügung stehende Bandbreite gleichmàßig auf.
Wenn die Teilnehmer sich jedoch (teilweise) nicht gegenseitig empfangen können,
kann es zu Störungen durch gleichzeitiges Senden kommen.

Das Dein WLAN-Treiber die Datenrate reduziert, spricht dafür, dass ihm in
Senderichtung viele Frames verloren gehen. Mehr dazu verràt Dir ein Aufruf
des Tools "athstats" (der Madwifi-Treiber meldet leider viele seiner Paketzàhler
nicht über die Wireless-Extensions zurück, wodurch iwconfig & co. dort
nur Nullen anzeigen. Intern wird da aber sehr genau Buch geführt...)

Da die Signalstàrke sehr gut aussieht (mit -50dBm vielleicht sogar etwas
*zu* gut!), würde ich den Paketverlust mal auf störende Nachbar-WLANs
schieben. Ich würde empfehlen, einfach mal die verschiedenen Kanàle
durchzuprobieren: der Kanal mit den "wenigsten" Nachbarn ist nicht unbedingt
der beste.

Du schreibst, dass Du eine Karte mit "AR5212/AR5213"-Chipsatz hast. Kann die
nicht auch 802.11a? Dann wàre mit einem passenden AP vielleicht die "Flucht" in
den 5GHz-Bereich für Dich möglich.

Ansonsten kannst Du versuchen, die Datenrate fest einzustellen, kannst mal
das "fragmentation threshold" hochsetzen, damit lange Frames in kurz aufgeteilt
werden, was ihre "Überlebenschance" erhöht, oder kannst mal mit RTS/CTS
experimentieren. An der "sensitivity" kannst Du bei Madwifi nicht rumschrauben.
Was sollte das auch bringen? Den eigenen Empfànger für die (schwachen) Aussendungen
der anderen "blind" zu machen, wàre sehr unkooperativ.


Gruß, Till.

e-mail: wollenberg (at) web (punkt) de

Ähnliche fragen