Forums Neueste Beiträge
 

Atheros WLAN unter Ubuntu Intrepid

01/11/2008 - 23:00 von Sebastian Kaps | Report spam
Hi!

Ich habe eine WLAN-Karte mit Atheros AR5213A Chip (Allnet ALL0281).
Unter Ubuntu Hardy lief die Karte einwandfrei mit dem madwifi-Treiber
(selbstkompiliert).
Jetzt habe ich auf Intrepid aktualisiert und seitdem habe ich nur
Probleme damit. Der ath5k-Treiber(*) funktioniert manchmal eine Weile,
um dann irgendwann mit Meldungen folgender Art abzuschmieren:
,-
| phy0: failed to set freq to 2422 MHz for scan
| ath5k phy0: noise floor calibration timeout (2412MHz)
| ath5k phy0: noise floor calibration timeout (2422MHz)
| ath5k phy0: can't reset hardware (-11)
`-

Also wollte ich wieder den madwifi-Treiber einsetzen. Ich habe mir eine
aktuelle Version aus dem SVN gezogen und kompiliert. Anschließend durfte
ich auch wpa_supplicant noch kompilieren, weil das in Intrepid
enthaltene kein madwifi mehr unterstützt.
Der Treiber làsst sich nun zwar laden, allerdings kann ich mich nicht
mehr mit meinem AP verbinden, da es immer einen Timeout gibt:
,-
| # wpa_supplicant -D madwifi -iath0 -c /etc/wpa_supplicant/wpasupp.conf
| CTRL-EVENT-SCAN-RESULTS
| Trying to associate with xx:xx:xx:xx:xx:xx (SSID='WLAN' freq$12 MHz)
| Associated with xx:xx:xx:xx:xx:xx
| WPA: 4-Way Handshake failed - pre-shared key may be incorrect
| CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
| CTRL-EVENT-SCAN-RESULTS
| Trying to associate with xx:xx:xx:xx:xx:xx (SSID='WLAN' freq$12 MHz)
| Authentication with xx:xx:xx:xx:xx:xx timed out.
| CTRL-EVENT-SCAN-RESULTS
| Trying to associate with xx:xx:xx:xx:xx:xx (SSID='WLAN' freq$12 MHz)
| Authentication with xx:xx:xx:xx:xx:xx timed out.
`-
Der PSK ist natürlich korrekt eingetragen.

Hat jemand eine Idee, wie ich die Karte wieder zum Laufen kriege?

(*) egal, ob der aus linux-backports-modules-intrepid oder aus einem
selbstkompilierten 2.6.28-rc2 Kernel.

Ciao, Sebastian
 

Lesen sie die antworten

#1 Bernd Hohmann
02/11/2008 - 00:55 | Warnen spam
Sebastian Kaps schrieb:

Jetzt habe ich auf Intrepid aktualisiert und seitdem habe ich nur
Probleme damit. Der ath5k-Treiber(*) funktioniert manchmal eine Weile,
um dann irgendwann mit Meldungen folgender Art abzuschmieren:



Fàngt ja gut an.

| WPA: 4-Way Handshake failed - pre-shared key may be incorrect


[...]
Der PSK ist natürlich korrekt eingetragen.

Hat jemand eine Idee, wie ich die Karte wieder zum Laufen kriege?



Nein - ausser, dass ich auf dem Aspire One nach dem letzten Update des
Kernels innerhalb von 8.04 wohl das gleiche Problem habe - scheint also
nicht alleine an Intrepid zu liegen.

Der funktionierende MadWifi HAL von 2008/08 machte nach dem Update beim
Kompilieren zicken sodass ich ath5k v0.9.4 gezogen habe. Der tat es
überhaupt nicht, also die HAL Variante von 2008/09 durchkompiliert.

Damit sehe ich im Network-Manager Applet zwar die Accesspoints,
verbinden geht nicht weil er auf irgendeinen Key wartet (Logfile hab ich
noch nicht durchforsten können).

Bernd

Well, there's egg and bacon; egg sausage and bacon; egg and
; egg bacon and spam; egg bacon sausage
and ; spam bacon sausage and spam;spam
egg spam spam bacon and ; spam sausage

Ähnliche fragen