Forums Neueste Beiträge
 

atril zeigt nur noch thumbnails (keinen Index)

30/03/2016 - 10:40 von Andreas Schmidt | Report spam


Hallo!

Ich habe gerade ein sehr komisches Problem, bei dem ich noch nicht
weiß, wo ich ansetzen sollte.

Ich bin gerade dabei, mit LaTeX ein recht großes Dokument zu erstellen.
Atril (der PDF-Viewer des MATE-Desktop) hatte in der Seitenleiste immer
schön die Gliederung ("Index") angezeigt. Gestern hatte ich die Anzeige
auf "Thumbnails" umgestellt, weil ich gerade viel mit Abbildungen zu
tun hatte und in diesem Fall Thumbnails einfach praktischer zum
Navigieren waren. Irgendwann wollte ich wieder zum Index
zurückschalten, aber im Menu sind nur die Punkte "Thumbnails",
"Annotations" und "Bookmarks" aktiv, "Index", "Attachments" und
"Layers" sind nicht auswàhlbar.

Erst dachte ich ja, dass pdflatex keinen Index mehr erzeugt hàtte;
allerdings zeigt mir xpdf die Dokumentstruktur richtig an. Anscheinend
stimmt also etwas mit atril nicht. Könnte vielleicht einmal jemand das
Beispiel im Anhang compilieren und schauen, wie atril das darstellt?
Möglicherweise habe ich ja mit einem Update etwas verdorben (unstable)
anderswo funktioniert ...

Danke und schönen Gruß

Andreas

PS: Noch die installierten atril-Pakete:

pc@debian:~$ dpkg -l | grep atril
ii atril
1.12.2-1 amd64 MATE document viewer
ii atril-common
1.12.2-1 all MATE document viewer
(common files)
ii libatrildocument3
1.12.2-1 amd64 MATE document
rendering library
ii libatrilview3
1.12.2-1 amd64 MATE document viewing
library
pc@debian:~$

\documentclass{report}
\usepackage[ngerman]{babel}
\usepackage[pdftex]{hyperref}
\usepackage{lipsum}

\begin{document}
\chapter{Test}
\section{Eins}
\lipsum
\section{Zwei}
\lipsum
\chapter{Text}
\lipsum\lipsum
\end{document}





 

Lesen sie die antworten

#1 Andreas Schmidt
30/03/2016 - 13:10 | Warnen spam

On 03/30/2016 10:37:02 AM, Andreas Schmidt wrote:
Erst dachte ich ja, dass pdflatex keinen Index mehr erzeugt hàtte;
allerdings zeigt mir xpdf die Dokumentstruktur richtig an.
Anscheinend stimmt also etwas mit atril nicht. Könnte vielleicht
einmal jemand das Beispiel im Anhang compilieren und schauen, wie
atril das darstellt? Möglicherweise habe ich ja mit einem Update
etwas verdorben (unstable) -- so richtig vorstellen kann ich mir das
zwar nicht, aber wenn es anderswo funktioniert ...



Als ich eine alte Version des PDF öffnete, war der Index wieder da.
Nachdem ich die Instanz von atril mit dem neuen PDF geschlossen hatte
und dann neu startete, ging es auch dort wieder. Wahrscheinlich war
diese atril-Instanz einfach zu lange geöffnet, so dass da doch ein
Update (für atril gab es gestern keines) für Verwirrung gesorgt hatte?
Allerdings hat checkrestart keine Leichen angezeigt -- gestern hatte
ich den Rechner neu gestartet, checkrestart beschwert sich jetzt nur
über dbus und libvirtd.

Jetzt geht also alles wieder -- nur was genau die Ursache dafür ist
(und warum es vorher nicht ging), interessiert mich immer noch... :-)

Schönen Tag noch

Andreas


Ähnliche fragen