Auf HP Notebook DV9830eg CPU dauernd auf ca. 48% Auslastung

05/01/2009 - 17:29 von Gerhard Regente | Report spam
Hallo,

erst einmal an alle Leser dieses Beitrages ein Frohes und Gesundes Neues
Jahr, verbunden mit der Hoffnung auf Windows 7

Nun zum eigentlichen Problem.
Dazu eine kurze Vorgeschichte. Ich habe Ende November 2008 ein System Image
(Acronis) als Backup gemacht. Anschließend ein paar Wochen in die Sonne ohne
jede Art von PC's. Es war kaum auszuhalten. Dann Weihnachten gefeiert und
zwischen den Jahren das Notebook angeworfen. Sonst wird eigentlich fast
alles am Hostrechner erledigt. Das Notebook (VISTA Ultimate 32) ist quasi so
ein (teueres) Hobby.
Jetzt die zwischendurch aufgelaufenen Microsoft Updates (19 Updates inkl.
Office) geholt und installiert.

Jetzt beginnt mein Problem:
Wenn das Notebook gebootet hat und alle Aktivitàten erledigt sind, zeigt ein
Gadgets in der Sidebar noch eine leicht schwankende CPU Belastung von ca.
48%. Mit dem Programm von Sysinternal (ProcExp) habe ich in der Anzeige den
Tàter gefunden. Der Windows-Explorer hat die hohe CPU Belastung. Wenn ich
auf diese Zeile einen Doppelclick mache, sehe ich im neuen Fenster bei dem
Reiter Threads bei der bei der ersten Eintragung:

TID #24, CPU= 48%, CSwitch DeltaW29*, Start Address= SHLWAPI.dll!Ordinal
197+0x57

wobei die Zahl bei * immer im Sekunden Modus wechselt und dabei auch die CPU
Speed sich immer um +/- 3% àndert.
Wenn ich auf diese Zeile einen Doppelclick ausführe kommt in dem neuen
Fenster folgender Inhalt zu Tage:

ntdll.dll!KiFastSystemCallRet
USER32.dll!SendMessageW+0x49
Explorer.EXE+0xc5db
Explorer.EXE+0xc5f9
Explorer.EXE+0xc63c
Explorer.EXE+0xcb5a
Explorer.EXE+0x28f61
Explorer.EXE+0x292f6
Explorer.EXE+0xe39d
Explorer.EXE+0xc69b
Explorer.EXE+0x8924
Explorer.EXE+0x1eef
USER32.dll!GetMessageW+0x93
USER32.dll!GetWindowLongW+0x115
USER32.dll!ReleaseDC+0x7a
USER32.dll!OpenInputDesktop+0x55
ntdll.dll!KiUserCallbackDispatcher+0x2e
USER32.dll!PeekMessageW+0x179
Explorer.EXE+0x1c8d
Explorer.EXE+0x2196c
SHLWAPI.dll!Ordinal197+0xfc
kernel32.dll!BaseThreadInitThunk+0x12
ntdll.dll!RtlInitializeExceptionChain+0x63
ntdll.dll!RtlInitializeExceptionChain+0x36


Die Datei SHLWAPI.dll wird noch bei mehreren TID's (3912, 4100, 4720, 5224,
5232, 5236 usw. insgesamt 11x aufgeführt. Da jedoch ohne jegliche CPU
Aktivitàt.

Wer kann mir dazu einen Hinweis geben, wie ich die CPU wieder etwas
beruhigen kann. So wie jetzt ist der Akku besonders schnell leer.

Was habe ich bisher versucht:
1. Restore mit dem Image vom Ende November. Anfangs erfreulich, dass der
Explorer sich normal verhielt.
2. Alle Updates wieder installiert. Nach einigen notwendigen Neustarts war
der Fehler leider wieder da.
3. jetzt die Updates einzeln deinstalliert, Neustart und den Fehler war
immer noch da.
4. Als ich alle 19 Updates wieder vom Rechner hatte, war der Fehler immer
noch da.

Ich hatte damit auf eines der Updates getippt. Leider aber nur eine gewisse
Zeit, nach einigen Neustarts war der Fehler wieder da.

5. Also noch einmal das Restore vom November Backup durchgeführt. Alle
wichtigen Programme (Virensignaturen) aktualisiert und einige Male gebootet.

Eigentlich alles OK und ich bin ins Bett gekrochen (Nachts um 04:00Uhr). Man
hat ja sonst nichts zu tun.

Heute Morgen als erstes natürlich das Notebook gestartet und ich bin fast
tot umgefallen. Der Fehler ist wieder da. An den Updates lag es also mit
Sicherheit nicht. Jetzt alle Updates wieder installiert. Ich wollte nicht
die wichtigen Updates verpassen und ev. einen Schaden in mein Netzwerk
bekommen. Besonders die Updates für den Internet Explorer.

Wer hat das Wissen von der Materie und kann mir die entscheidenden Tipps
geben. Bevor ich eine Neuinstallation des Notebooks mache, möchte ich erst
mit Sicherheit wissen woher das Verhalten kommt.

Liebe NG-User, ihr seht wie schlecht es mir geht. Jetzt docktere ich schon
zwei Tage am Notebook herum, ohne das etwas Brauchbares herausgekommen ist.

ciao
gerd
 

Lesen sie die antworten

#1 Hans-Peter Matthess
05/01/2009 - 23:04 | Warnen spam
Gerhard Regente:

Wenn das Notebook gebootet hat und alle Aktivitàten erledigt sind, zeigt ein
Gadgets in der Sidebar noch eine leicht schwankende CPU Belastung von ca.
48%.



Und die bleibt wie lange bestehen? Offensichtlich sind also nicht alle
Aktivitàten erledigt, sonst gàbe es ja keine CPU-Aktivitàt von 48%.

Mit dem Programm von Sysinternal (ProcExp) habe ich in der Anzeige den
Tàter gefunden.



Warum dieses Tool? Windows besitzt einen Task-Manager in dem man die
CPU-Aktivitàt der einzelnen Tasks erkennen kann. Was wird denn da
angezeigt?

Der Windows-Explorer hat die hohe CPU Belastung.



Also zeigt der Task "Explorer.exe" im *Task-Manager* diese Aktivitàt?
Hast du denn schon mal den Systemstart bereinigt? *Restlos* alle
Nicht-Windows-Dienste deaktiviert, ebenso restlos alle Nicht-Windows
Autostart-Tasks deaktiviert? Wenn das keine Wirkung zeigt, könnte man
zusàtzlich testweise auch mal die Aufgabenplanung deaktivieren.

hpm

Ähnliche fragen