Ausgabe einer Liste von gekennzeichneten Werten

25/04/2009 - 21:51 von Rainer Nowaczyk | Report spam
Hallo Ihr Wissenden,

ich habe folgendes Excel-Problem:

Ich habe eine Liste mit (Namens-)Werten. Verschiedene Werte sind in der
nàchsten Spalte mit einem X gekennzeichnet. Ich suche nun nach einer
Möglichkeit, dass Excel nur die mit X gekennzeichneten Werte in ein neues
Tabellenblatt schreibt. Hier mein Beispiel:

Ausgangspunkt:
A B
1 Vorname1 | X
2 Vorname2 |
3 Vorname3 |
4 Vorname4 | X
5 Vorname5 |
...


Soll-Ergebnis:
A B
1 Vorname1 | X
2 Vorname4 | X
...


Liebe Grüße
Rainer Nowaczyk
 

Lesen sie die antworten

#1 Dietmar Vollmeier
25/04/2009 - 22:32 | Warnen spam
Servus Rainer!

*Rainer Nowaczyk* schrieb am 25.04.2009 um 21:51 Uhr...
Ich habe eine Liste mit (Namens-)Werten. Verschiedene Werte sind in der
nàchsten Spalte mit einem X gekennzeichnet. Ich suche nun nach einer
Möglichkeit, dass Excel nur die mit X gekennzeichneten Werte in ein neues
Tabellenblatt schreibt. Hier mein Beispiel:

Ausgangspunkt:
A B
1 Vorname1 | X
2 Vorname2 |
3 Vorname3 |
4 Vorname4 | X
5 Vorname5 |
...



Benenne diesen Bereich von A1:B? z.B. als "Vornamen"

Soll-Ergebnis:
A B
1 Vorname1 | X
2 Vorname4 | X
...



Gib in einem neuen Tabellenblatt folgende Formel in Spalte A ein und
schließe diese mit [Strg]+[Shift]+[Enter] ab (Matrixformel).
Anschließend kopiere diese soweit wie gewünscht nacht unten.

=WENN(ZEILE(A1)>ZÄHLENWENN(INDEX(Vornamen;;2);"<>"&"");"";INDEX(Vornamen;KGRÖSSTE((INDEX(Vornamen;;2)<>"")*ZEILE(Vornamen);ZEILE(A1));1))

Für Spalte B benutze diese Formel (nur mit [Enter] abschließen)

=WENN(ISTNV(VERWEIS(A1;Vornamen));"";VERWEIS(A1;Vornamen))

alternativ funktioniert auch

=WENN(A1="";"";"X")
und tschüss | Wenn die Leute Hàuser so bauen würden, wie wir Programme
Didi | schreiben, würde der erstbeste Specht unsere Zivilisation
| zerhacken.

Ähnliche fragen