Auswertung von Zuordnung (aus SVERWEIS)

25/10/2007 - 09:05 von Andreas Wenzke | Report spam
Hallo NG!

Ich habe eine solche Tabelle (ohne Leerzeilen):

Gruppe Name Zuordnung
==1 A X
1 B Y
1 C X

2 D Z
2 E #NV
2 F K

3 G #NV
3 H #NV
3 I #NV

Die Zuordnung erfolg via SVERWEIS, deshalb steht dort teilweise "#NV".

Nun möchte ich gern:

a) Pro Gruppe eine Zuordnung erhalten, also etwa ZUORDNUNG(2) sollte Z
oder K liefern.

b) Die Gruppen, die gar keine Zuordnung haben (hier also Gruppe 3)
sollen irgendwie auffindbar sein, also am besten rot hinterlegt.

c) Ich möchte gern wissen, wieviele aller Gruppen gar keine Zuordnung
haben (hier nur die 3, also eine von drei Gruppen).
Muss nicht automatisiert sein.

Wie kann ich das tun?
Im Voraus vielen Dank.

Liebe Grüße,
Andreas
 

Lesen sie die antworten

#1 Eberhard Funke
25/10/2007 - 12:05 | Warnen spam
Am Thu, 25 Oct 2007 09:05:09 +0200 schrieb Andreas Wenzke:

Ich habe eine solche Tabelle (ohne Leerzeilen):

Gruppe Name Zuordnung
==> 1 A X
1 B Y
1 C X

2 D Z
2 E #NV
2 F K

3 G #NV
3 H #NV
3 I #NV

Die Zuordnung erfolg via SVERWEIS, deshalb steht dort teilweise "#NV".

Nun möchte ich gern:

a) Pro Gruppe eine Zuordnung erhalten, also etwa ZUORDNUNG(2) sollte Z
oder K liefern.

b) Die Gruppen, die gar keine Zuordnung haben (hier also Gruppe 3)
sollen irgendwie auffindbar sein, also am besten rot hinterlegt.

c) Ich möchte gern wissen, wieviele aller Gruppen gar keine Zuordnung
haben (hier nur die 3, also eine von drei Gruppen).
Muss nicht automatisiert sein.




Hallo Andreas

Datenanordnung:
Zeile 1 ist *leer* !!
Die Daten (mit den Überschriften) stehen in A2:C1
(also ohne die Zeile "==")

D3: =WENN(REST(ZEILE()-1;3)=1;INDEX(C:C;WENN(REST(ZEILE();3)-1=1;
KGRÖSSTE(NICHT(ISTFEHLER(C2:C3))*ZEILE(C2:C3);1);""););"")

Die Formel muss mit der Tastenkombination Shift+Strg+Enter abgeschlossen
werden (Matrixformel).

Runterkopieren bis zur letzten Zeile des Datenfeldes (wenn Du weiter
runterziehst, wird in Spalte D alles unterhalb Deines Datenfeldes durch die
Bed. Formatierung gefàrbt. Ausserdem wird die Anzahl der Gruppen ohne
Zuordnung falsch berechnet!)

Ab D3 bis letzte Zeile des Datenfeldes markieren, Menü Format -->
Bedingte Formatierung --> Formel ist: Ó=0

Für die Anzahl der nicht zugeordneten Gruppen:
=ZÄHLENWENN(D:D;0)
(darf natürlich nicht in Spalte D stehen)

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen