Authentifizierung über HTTPS

04/09/2007 - 13:14 von Bernhard | Report spam
Ich betreibe einen MS ISA Server 2006 Standard, der àhnlich wie beim SBS
gemeinsam auf einer Maschine (die unter Windows 2003 Server R2 SP-2, als
Domànencontroller mit AD) mit IIS und Exchange 2003 SP-2 làuft. Der Rechner
hat zwei NICs, eine direkt mit dem Internet verbunden, eine Weitere ins
interne LAN.
Mein Problem ist, dass ich einige Seiten habe die ich vom Internet aus über
HTTPS anbieten möchte, weil sich User dafür authentifizieren müssen (über
User im AD). Leider funktioniert das aus mir unerklàrlkichen Gründen nicht.
Wenn die Seite von extern aufgerufen wird, kommt die Authentifizierungsmaske
vom ISA Server, nur in diese kann ich eingeben was immer ich will. Es kommt
weder eine Fehlermeldung, noch eine weitere oder geànderte Maske. ich bekomme
IMMER die leere Authentifizierungsmaske zurück.
Ich habe dann testweise die Authentifizierung über HTTP erlaubt und siehe
da, hier kommt zwar nur die normale POPup Maske zum eingeben von Benutzername
und Passwort, aber nach Eingabe dieser funktioniert es wunderbar.
Was habe ich bei der HTTPS Lösung falsch gemacht?
 

Lesen sie die antworten

#1 Martin Resch
04/09/2007 - 13:59 | Warnen spam
Hi Bernhard,

Ich habe dann testweise die Authentifizierung über HTTP erlaubt und siehe
da, hier kommt zwar nur die normale POPup Maske zum eingeben von Benutzername
und Passwort, aber nach Eingabe dieser funktioniert es wunderbar.
Was habe ich bei der HTTPS Lösung falsch gemacht?



Ist das Zertifikat übereinstimmend mit der externen IP/DN?

Gruß
Martin

Ähnliche fragen