Auto Accept Agent Installationsproblem

05/09/2007 - 12:02 von Ralf Rudolph | Report spam
Hallo!

Wir verwenden SBS 2003 (Windows 2003 SP2, ohne R2) und Exchange 2003 (Build
7226.6 SP1). Wir möchten Konferenzràume als Ressourcen mit Exchange 2003
verwalten. Nach einem Umweg über Direct Booking, was aber ein Outlook-Feature
ist und daher nur bei geöffnetem Postfach funktioniert, haben wir
herausgefunden, dass der Auto Accept Agent (AAA) das richtige Werkzeug ist:
Er làuft auf dem Server und beantwortet die Buchungen für die
Ressourcen-Postfàcher.

Leider können wir den AAA nicht installieren: Wàhrend der Installation
erscheint die Fehlermeldung "There is a problem with this Windows Installer
package. A program run as part of the setup did not finish as expected.
Contact your support personnel or package vendor.". Danach wird die
Installation rückgàngig gemacht.

Wir haben bereits
- mehrfach versucht, den AAA zu installieren (obige Fehlermeldung), zu
deinstallieren ("not installed") oder zu reparieren ("not installed")
- sichergestellt, dass die Dienste MSDTC und COM+ laufen, und die Dienste
neu gestartet
- alle aktuellen Updates per updates.microsoft.com aufgespielt
- das Paket neu heruntergeladen
- den Server neu gestartet
- den Installationspfad variiert (c:\program files\... anstelle von
c:\programme\... verwendet, oder c:\AutoAccept versucht)
- versucht, den MSI 3.1 erneut zu installieren (geht nicht, da eine neuere
Version bereits installiert ist)
- versucht, dotnet runtime 1.1 zu installieren (das geht aber nicht, da eine
neuere Version bereits bestandteil des Betriebssystems ist)
- versucht, dotnet 1.1 SP1 aufzuspielen (geht ebenfalls nicht, da keine
kompatible Version vorhanden ist)
- dotnet runtime 2.0 installiert
- den "echten" Administrator-Account verwendet anstelle eines persönlichen
Accounts mit Administratorrechten

Der AAA ist digital signiert von Microsoft (July 21st, 2005) und hat die
Bezeichnung "Auto Accept Agent v6.5.7618.0". In der rgebnisanzeige
"Anwendung" werden wàhrend der Installation folgende Eintràge erzeugt:

Ereignistyp: Fehler
Ereignisquelle: MsiInstaller
Ereigniskategorie: Keine
Ereigniskennung: 11722
Datum: 04.09.2007
Zeit: 22:02:00
Benutzer: xxx\xxx
Computer: xxx
Beschreibung:
Product: Auto Accept Agent -- Error 1722. There is a problem with this
Windows Installer package. A program run as part of the setup did not finish
as expected. Contact your support personnel or package vendor. Action
CA_AutoAcceptInstaller.install, location:
C:\Programme\Exchsrvr\Agents\AutoAccept\Bin\AutoAcceptInstaller.exe, command:
INSTALL 5

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter
http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 7b 44 34 38 46 44 39 34 {D48FD94
0008: 37 2d 35 35 38 31 2d 34 7-5581-4
0010: 44 43 45 2d 42 31 45 42 DCE-B1EB
0018: 2d 38 37 36 32 37 43 31 -87627C1
0020: 30 31 44 34 38 7d 01D48}

sowie

Ereignistyp: Informationen
Ereignisquelle: MsiInstaller
Ereigniskategorie: Keine
Ereigniskennung: 11708
Datum: 04.09.2007
Zeit: 22:02:06
Benutzer: xxx\xxx
Computer: xxx
Beschreibung:
Product: Auto Accept Agent -- Installation failed.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter
http://go.microsoft.com/fwlink/events.asp.
Daten:
0000: 7b 44 34 38 46 44 39 34 {D48FD94
0008: 37 2d 35 35 38 31 2d 34 7-5581-4
0010: 44 43 45 2d 42 31 45 42 DCE-B1EB
0018: 2d 38 37 36 32 37 43 31 -87627C1
0020: 30 31 44 34 38 7d 01D48}


Der interessante Teil ist etwa in der Mitte der Fehlermeldung und lautet:
Action CA_AutoAcceptInstaller.install, location:
C:\Programme\Exchsrvr\Agents\AutoAccept\Bin\AutoAcceptInstaller.exe, command:
INSTALL 5

Wàhrend der Installer den Fehler anzeigt, sind alle Dateien unter
C:\Programme\Exchsrvr\Agents\AutoAccept vorhanden - erst nach Bestàtigung der
Fehlermeldung werden sie wieder gelöscht. Ich habe eine Kopie des
Verzeichnisses gemacht und bin der Ansicht, dass alle Dateien gut aussehen
(soweit ich das beurteilen kann). Auch der fragliche Befehl
AutoAcceptInstaller.exe ließ sich ausführen - ohne Fehlermeldung und mit
Returncode 0x00 (also OK). Aber ich weiß natürlich nicht, was sonst noch zur
Installation durchgeführt werden muss.

Durch googeln nach dem Begriff 87627C1 (Bestandteil der Fehlermeldung) habe
ich herausgefunden, dass auch andere Anwender dieses Problem hatten - aber
eine Lösung war nicht zu erkennen.

Ich habe das Problem bereits in der englischsprachigen MS Partner newsgroup
"Exchange 2003 Administration (retiring)" unter dem Titel "SBS 2003 -
Resource requests - Auto Accept Agent" vorgetragen. Dort haben wir
herausgefunden, dass Directbooking für unser Problem ungeeignet ist und wir
den AAA benötigen. Zu unserem konkreten Problem wurden wir freundlich aber
bestimmt auf die deutsche Newsgroup verwiesen - Nun hoffe ich, hier kann uns
geholfen werden :-)

So langsam gehen uns die Ideen aus - das vorliegende Installationsproblem
mit dem AAA scheint zwar selten zu sein, aber es kommt auch bei anderen
Anwendern vor. Der Server ist seit 2 Jahren im Produktiveinsatz und sehr
pfleglich behandelt worden (keine fragwürdigen Experimente, keine sonstige
Software etc.).

Wir würden uns über jeden Hinweis freuen, der zur Problemlösung beitràgt!
Konkrete Fragen wàren:
- Gibt es jemanden, der dieses Problem schon einmal lösen konnte?
- Wie kann ein detailiertes Aktivitàten-Log des Installers angefertigt werden?
- Gibt es Alternativen zum AAA?
- Wie bekommen wir es einfach zum Laufen??? ;-)

Viele Grüße
Ralf Rudolph
 

Lesen sie die antworten

#1 Walter Steinsdorfer [MVP]
05/09/2007 - 12:22 | Warnen spam
Hi,


- Gibt es Alternativen zum AAA?



imho nein (Exchange 2007, aber das wollt ihr wahrscheinlich nicht extra
kaufen)

- Wie bekommen wir es einfach zum Laufen??? ;-)



ruft bei MS PSS an.

Viele Grüße aus München
Walter Steinsdorfer, MVP Exchange Server
https://mvp.support.microsoft.com/d...5C7782F6AD
Windows 2003 die Expertentipps:
http://www.faq-o-matic.net/content/view/253/2/

Ähnliche fragen