Autoexec versucht zu starten vor Makro Sicherheitsabfrage Access 2

25/09/2009 - 13:14 von Ralf Dorn | Report spam
Hallo alle zusammen,

habe eine DB die in Access XP einwandfrei funktioniert und jetzt mit Access
2007 Probleme macht.

Habe in der Autoexec ein VBA Modul das eine Funktion startet. Diese wird
jetzt versucht aufzurufen bevor ich die Erlaubnis gebe Makros auszuführen.

Ich unserer Firma kann man die Sicherheitsstufe nicht auf niedrig schalten
da beim nàchsten Start die Stufe wieder hoch ist. Also muss man eben immer
beim ersten Start die Erlaubnis geben.

Nur jetzt bekomme ich eben einen Fehler dass das Makro Autoexec einen fehler
hàtte. Klicke ich die Meldung mit OK weg startet die DB wie gewohnt und wenn
ich dann die Erlaubnis für Makros gebe wird auch mein Autoexec einwandfrei
ausgeführt.

Ich muss noch dazu sagen dass ich die DB im Access XP Format abgespeichert
habe weil wir im Betrieb verschiedene Versionen haben und ich es vorgezogen
habe die DB im .mdb Format abzuspeichern.

Liegt es daran?

Gruß

Ralf Dorn
 

Lesen sie die antworten

#1 Henry Habermacher
25/09/2009 - 14:34 | Warnen spam
Hallo Ralf

Auf den VBA Code im Makro zu verzichten geht nicht? Also z.B. den Code in
ein Marko umschreiben?
Hast Du mal versucht, auf das Autoexec Makro zu verzichten und statt dessen
den Code in einem Startup Formular auszufuehren. Ich denke, dass fuer ein
Formular die Makro Abfrage frueher kommt.

Ansonsten: Wenn die Makrosicherheit nicht ausgeschaltet werden kann: Hast Du
die Moeglichkeit vertrauenswuerdige Speicherorte anzulegen, z.B. auf der
lokalen Platte? Falls ja, koenntest Du die Anwendung darueber freischalten.

Gruss
Henry

Ralf Dorn wrote:
habe eine DB die in Access XP einwandfrei funktioniert und jetzt mit
Access 2007 Probleme macht.

Habe in der Autoexec ein VBA Modul das eine Funktion startet. Diese
wird jetzt versucht aufzurufen bevor ich die Erlaubnis gebe Makros
auszuführen.

Ich unserer Firma kann man die Sicherheitsstufe nicht auf niedrig
schalten da beim nàchsten Start die Stufe wieder hoch ist. Also muss
man eben immer beim ersten Start die Erlaubnis geben.

Nur jetzt bekomme ich eben einen Fehler dass das Makro Autoexec einen
fehler hàtte. Klicke ich die Meldung mit OK weg startet die DB wie
gewohnt und wenn ich dann die Erlaubnis für Makros gebe wird auch
mein Autoexec einwandfrei ausgeführt.

Ich muss noch dazu sagen dass ich die DB im Access XP Format
abgespeichert habe weil wir im Betrieb verschiedene Versionen haben
und ich es vorgezogen habe die DB im .mdb Format abzuspeichern.



Microsoft MVP Office Access
Access FAQ www.donkarl.com
Keine E-Mails auf Postings in NGs

Ähnliche fragen