Autofill

03/04/2010 - 11:08 von Förster | Report spam
Hallo liebe Experten,

wie kann ich das nachstehende Makro so veràndern, dass immer die
aktive Zelle als SourceRange genommen wird und die FillRange immer die
Spalten B:FN beinhaltet, so dass ich nicht jedesmal die Bezüge (B37 bzw.
B37:FN37) àndern muss, wenn aus einer anderen Zelle (z.B. B38) kopiert werden
soll.

Set SourceRange = Worksheets("Tabelle1").Range("b37")
Set fillRange = Worksheets("Tabelle1").Range("B37:FN37")
SourceRange.AutoFill Destination:=fillRange

In der aktiven Zelle (B37) steht die Formel:

=WENN(ISTFEHLER(INDEX('K:\ARTIKELAUSWERTUNG\auswertjan2010.xls'!liste;
VERGLEICH(B$30; 'K:\ARTIKELAUSWERTUNG\auswertjan2010.xls'!artnr;0);2)); "0 ";
INDEX('K:\ARTIKELAUSWERTUNG\auswertjan2010.xls'!liste; VERGLEICH(B$30;
'K:\ARTIKELAUSWERTUNG\auswertjan2010.xls'!artnr;0);2))

Kann man diese Formel in ein Makro integrieren, in dem die Quelldatei
(auswertjan2010.xls) abgefragt wird (auswertung Januar àndert sich in
Auswertung Februar etc.). Notfalls muss ich wohl die Quelldatei immer unter
dem gleichen Namen speichern.

Vielen Dank im voraus für jede Hilfe
und frohe Ostern

Grüße
Renate
 

Lesen sie die antworten

#1 Peter Schleif
03/04/2010 - 12:46 | Warnen spam
Förster schrieb am 03.Apr.2010 11:08 Uhr:

wie kann ich das nachstehende Makro so veràndern, dass immer die
aktive Zelle als SourceRange genommen wird und die FillRange immer die
Spalten B:FN beinhaltet



Indem Du ActiveCell verwendest. Das bezieht sich allerdings immer auf
das aktive Worksheet. Du musst darum dafür sorgen, dass Tabelle1 aktiv
ist, falls dies nicht schon vor Ausführung des Codes so ist.

Worksheets("Tabelle1").Select
ActiveCell.AutoFill Range(ActiveCell, Cells(ActiveCell.Row,"FN"))

Peter

Ähnliche fragen