Autofilter nochmal

27/09/2007 - 20:28 von Michael Paetz | Report spam
Hallo liebe NGs
ich habe die frage schon weiter unten gestellt und die antwort von Claus
Busch erschien logisch. Leider löst sie das problem nicht. Auch mit dem
anderen datumsformat wird der Filter nicht korrekt ausgeführt, soll heißen:
es wird ein Filter ausgeführt der nicht zutrifft, da keine Daten mehr
angezeigt werden. Wenn mit der mouse der benutzerdefinierte filter
aufgerufen wird, wird dieser korrekt angezeigt und nach klicken auf ok auch
richtig ausgeführt. Hier der code:

Selection.AutoFilter Field:=2, Criteria1:=">.01.2007", Operator:=xlAnd _
, Criteria2:="<&.09.2007"
Ein zweiter filter in Field1 wird problemlos ausgeführt.
Wer kann helfen??
Vielen Dank
Michael
 

Lesen sie die antworten

#1 Claus Busch
27/09/2007 - 20:49 | Warnen spam
Hallo Michael,

"Michael Paetz" wrote:

ich habe die frage schon weiter unten gestellt und die antwort von Claus
Busch erschien logisch. Leider löst sie das problem nicht. Auch mit dem
anderen datumsformat wird der Filter nicht korrekt ausgeführt, soll heißen:
es wird ein Filter ausgeführt der nicht zutrifft, da keine Daten mehr
angezeigt werden. Wenn mit der mouse der benutzerdefinierte filter
aufgerufen wird, wird dieser korrekt angezeigt und nach klicken auf ok auch
richtig ausgeführt. Hier der code:

Selection.AutoFilter Field:=2, Criteria1:=">.01.2007", Operator:=xlAnd _
, Criteria2:="<&.09.2007"
Ein zweiter filter in Field1 wird problemlos ausgeführt.



bei Field:=2 handelt es sich um die 2. Spalte in der Selection. Du müsstest
also Spalte A + Spalte B selektieren, wenn du damit Datumswerte in B filtern
möchtest.
Warum gibst du den Bereich nicht explizit an? Z.B. so für Spalte A:
Range("A1").AutoFilter Field:=1, _
Criteria1:="> /04/2007", _
Operator:=xlAnd, _
Criteria2:="< /17/2007"

Mit freundlichen Grüßen
Claus Busch

Ähnliche fragen